HDU - 6092 Rikka with Subset

Rikka with Subset

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 412    Accepted Submission(s): 178


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has  n  positive  A1An  and their sum is  m . Then for each subset  S  of  A , Yuta calculates the sum of  S

Now, Yuta has got  2n  numbers between  [0,m] . For each  i[0,m] , he counts the number of  i s he got as  Bi .

Yuta shows Rikka the array  Bi  and he wants Rikka to restore  A1An .

It is too difficult for Rikka. Can you help her?  
 

Input
The first line contains a number  t(1t70) , the number of the testcases. 

For each testcase, the first line contains two numbers  n,m(1n50,1m104) .

The second line contains  m+1  numbers  B0Bm(0Bi2n) .
 

Output
For each testcase, print a single line with  n  numbers  A1An .

It is guaranteed that there exists at least one solution. And if there are different solutions, print the lexicographic minimum one.
 

Sample Input
    
    
2 2 3 1 1 1 1 3 3 1 3 3 1
 

Sample Output
    
    
1 2 1 1 1
Hint
In the first sample, $A$ is $[1,2]$. $A$ has four subsets $[],[1],[2],[1,2]$ and the sums of each subset are $0,1,2,3$. So $B=[1,1,1,1]$
 

Source
 

题目大意:

有一个数列 a[] ,长度(n<=50)。b[i] 表示元素和为 i 的集合个数。给你一个数列 b[] ,长度(m<=10000),让你求 a[],并按照其字典序最小输出。

分析:

首先,对于除了 b0 以外的第一个不为 0 的 bi ,数组 a[] 里面一定有 i,并且有 b[i]个(但是我不是一次就把这 b[i] 个一次性全拿出来,我一个一个拿) 。首先进行完拿出一个的操作之后,然后要对 b 进行操作,把 b 数组变成去除 i 后继续满足原定义。首先考虑,对于每一个和为 j 的组合(元素中没有 i ),把它里面加上一个元素 i 它就变成了一个和为 j+i 的组合。 
也就是说: 

j+iji=j+ii

所以按照这种方法就可以在:O(mn) 的时间内得到 n 个数,然后按照字典序最小输出即可。

注意尾部不能有空格。

代码:

#include<bits/stdc++.h>
using namespace std;
int t,n,m;
long long int b[10050]={0};
int a[600]={0};
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        memset(b,0,sizeof(b));
        memset(a,0,sizeof(a));

        scanf("%d%d",&n,&m);
        for(int i=0;i<=m;i++)
        {
            scanf("%I64d",&b[i]);
        }
        int k=0;
        for(int i=1;i<=m;i++)
        {
            if(k>=n)break;
            if(i<=0)continue;

            if(b[i]!=0)
            {
                a[k]=i;
                k++;
                for(int j=i;j<=m;j++)
                {
                    b[j]=b[j]-b[j-i];
                }
                i--;
            }
        }
        printf("%d",a[0]);
        for(int i=1;i<k;i++)
        {
            printf(" %d",a[i]);
        }
        printf("\n");
    }

}

   
   
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
  • 38
  • 39
  • 40
  • 41
  • 42
  • 43
  • 44
  • 45
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
  • 38
  • 39
  • 40
  • 41
  • 42
  • 43
  • 44
  • 45

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值