Rikka with Subset HDU - 6092 (傻瓜01背包)

As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has nn positive A1−AnA1−An and their sum is mm. Then for each subset SS of AA, Yuta calculates the sum of SS.

Now, Yuta has got 2n2n numbers between [0,m][0,m]. For each i∈[0,m]i∈[0,m], he counts the number of iis he got as BiBi.

Yuta shows Rikka the array BiBi and he wants Rikka to restore A1−AnA1−An.

It is too difficult for Rikka. Can you help her?
Input
The first line contains a number t(1≤t≤70)t(1≤t≤70), the number of the testcases.

For each testcase, the first line contains two numbers n,m(1≤n≤50,1≤m≤104)n,m(1≤n≤50,1≤m≤104).

The second line contains m+1m+1 numbers B0−Bm(0≤Bi≤2n)B0−Bm(0≤Bi≤2n).
Output
For each testcase, print a single line with nn numbers A1−AnA1−An.

It is guaranteed that there exists at least one solution. And if there are different solutions, print the lexicographic minimum one.
Sample Input
2
2 3
1 1 1 1
3 3
1 3 3 1
Sample Output
1 2
1 1 1

Hint
In the first sample, A is [1,2]. A has four subsets [],[1],[2],[1,2] and the sums of each subset are 0,1,2,3 . So B=[1,1,1,1]

不知道为啥每次说到01背包我都用傻瓜这个词。。婊一波出题人 什么瞎几把题意,读题读得烦影响思路
题意:给定你 0到m 每个数的个数 这些个数都是A 的子集的和。让你构造出A序列,就是考虑已知的数怎么构造出 和的值 就是从小到大构造,这样就没有后效性了。。

就是把每一个集合的和当成一个个体进行01背包就好 往后面消除
这里是把每个数当成一个独立的个体 例如3个1 那么3个1我不管拿的顺序,只用知道是独立的个体就好,但是有些写法是利用组合数整合成一个个体,就是你用多个组合的时候必须得考虑组合的是哪几个所以要用到组合数。思想上的不同就是这样了,代码运行中的不同想不到。

#include <bits/stdc++.h>

using namespace std;
const int maxn = 1e4+100;
typedef long long ll;
ll b[maxn];
ll dp[maxn];

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=0;i<=m;i++)
            scanf("%lld",&b[i]);
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        for(int i=1;i<=m;i++)
        {
            int hh=b[i]-dp[i];
            b[i]-=dp[i];
            for(int j=1;j<=hh;j++)
            {
                for(int k=m;k>=i;k--)
                {
                    dp[k]+=dp[k-i];
                }
            }
        }
        int f=0;
        for(int i=1;i<=m;i++)
        {
            while(b[i]>0)
            {
                if(f) printf(" ");
                f=1;
                b[i]--;
                printf("%d",i );
            }
        }
        printf("\n");
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值