hdu 多校联赛 6092 Rikka with Subset

Rikka with Subset

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has  n  positive  A1An  and their sum is  m . Then for each subset  S  of  A , Yuta calculates the sum of  S

Now, Yuta has got  2n  numbers between  [0,m] . For each  i[0,m] , he counts the number of  i s he got as  Bi .

Yuta shows Rikka the array  Bi  and he wants Rikka to restore  A1An .

It is too difficult for Rikka. Can you help her?  
 

Input
The first line contains a number  t(1t70) , the number of the testcases. 

For each testcase, the first line contains two numbers  n,m(1n50,1m104) .

The second line contains  m+1  numbers  B0Bm(0Bi2n) .
 

Output
For each testcase, print a single line with  n  numbers  A1An .

It is guaranteed that there exists at least one solution. And if there are different solutions, print the lexicographic minimum one.
 

Sample Input
  
  
2 2 3 1 1 1 1 3 3 1 3 3 1
 

Sample Output
  
  
1 2 1 1 1
Hint
In the first sample, $A$ is $[1,2]$. $A$ has four subsets $[],[1],[2],[1,2]$ and the sums of each subset are $0,1,2,3$. So $B=[1,1,1,1]$
 

Source


题意:比赛的时候就没看懂题意 赛后补题也没看懂 感觉题目之间量的关系都描述的不清晰 根据多方查询+百度+瞎猜才明白了个大体意思 题目先说了有A这个数组 数组有n个数 n已知 然后这个数组能形成2^n个子集(子集的解释看样例)这2的n次方个A的子集的和的大小为i  i在(0,m)内  其中m是确定已知的 然后这些子集和为i的数量又形成了数组B 数组B也已知 现在然你回过头来求A(感觉真的是够绕的……)
解析: 很多个较小的数字随机组合会求出多个很大的数字,所以从B0向Bm推导,在每求出A序列的一部分这个过程中,更新后续的B序列,更新完的B[i]就是 i 在A序列中出现的次数。 
分析完后,主要的难点就是怎么去让已求出来的A序列随机组合,更新后续的B序列直接减就可以了。看成01背包问题,让m为背包去装 i,初始值为dp[0] = 1,由于i依次增大,A子集随机组合不会重复
ac代码:
#include <bits/stdc++.h>
#define N 10010
using namespace std;
int a[N], b[N], dp[N],c[N];
//dp[i]表示:加和为i的子集个数;
int main()
{
    int t, n, m;
    scanf("%d", &t);
    while(t--)
    {//先清空所有数组
        memset(a, 0, sizeof(a));//用来存储求得的a数组的值
        memset(b, 0, sizeof(b));//存储输入的到的b数组的值
        memset(dp, 0, sizeof(dp));//用来存储dp过程中规划的过程值
        scanf("%d %d", &n, &m);
        for(int i = 0; i <= m; i++)
            scanf("%d", &b[i]);//读取b数组
        dp[0] = 1;//初始化规划数组的初值
        int p = 0;//中间变量 做a数组的下标
        for(int i = 1; i <= m; i++)
        {
            c[i] = b[i] - dp[i];//c数组存储A序列中值为i的个数
            for(int j = 0; j < c[i]; j++)
            {
                a[p++] = i; //对A序列赋值
                for(int k = m; k>= i; k--) //处理成01背包
                {

                    dp[k] += dp[k - i]; //和为k的A子集个数相加去更新B序列
                }
            }
        }
        for(int i = 0; i < p; i++)
        {
            if(i > 0) printf(" ");//注意规范输出格式 防止re
            printf("%d", a[i]);//输出A序列
        }
        printf("\n");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值