hdu 6168 Numbers(多校联赛)

Numbers

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 13    Accepted Submission(s): 9


Problem Description
zk has n numbers  a1,a2,...,an . For each (i,j) satisfying 1≤i<j≤n, zk generates a new number  (ai+aj) . These new numbers could make up a new sequence  b1b2,...,bn(n1)/2 .
LsF wants to make some trouble. While zk is sleeping, Lsf mixed up sequence a and b with random order so that zk can't figure out which numbers were in a or b. "I'm angry!", says zk.
Can you help zk find out which n numbers were originally in a?
 

Input
Multiple test cases(not exceed 10).
For each test case:
The first line is an integer m(0≤m≤125250), indicating the total length of a and b. It's guaranteed m can be formed as n(n+1)/2.
The second line contains m numbers, indicating the mixed sequence of a and b.
Each  ai  is in [1,10^9]
 

Output
For each test case, output two lines.
The first line is an integer n, indicating the length of sequence a;
The second line should contain n space-seprated integers  a1,a2,...,an(a1a2...an) . These are numbers in sequence a.
It's guaranteed that there is only one solution for each case.
 

Sample Input
  
  
6 2 2 2 4 4 4 21 1 2 3 3 4 4 5 5 5 6 6 6 7 7 7 8 8 9 9 10 11
 

Sample Output
  
  
3 2 2 2 6 1 2 3 4 5 6

比赛也快结束了 感觉自己越来越菜了 就做出来一道题 写一下今天唯一的成果吧 只做出来了1008 

题意:给你一个队列 这个队列是由数列a和b混合起来的 a数列长度为n b数列长度为n(n-1)/2期中b数列为ai+aj i和j在1到n的范围之内 让你根据给出的数列求出a数列来 

思路:刚开始做的时候 暴力一发然后tle了 人后听别的队用优先队列做的 于是也改成了优先队列  因为给你的是一个混合的总的数列 所以要根据a数列 把b数列踢出 剩下的就都是a数列了 而且这一个过程要一边踢一边存 这样才不会对后续的过程产生影响 但是队列又不能从中间删除元素 所以用一个辅助的队列来存应该被删除的数

过程:把序列存到优先队列去 排序后数列的前两个肯定是a数列的前两个元素 弹出这两元素放到集合a里去 然后把这两个数生成的b放到辅助队列中 让辅助队列顶元素去和主队列顶元素对比 如果相同 就把这个元素都弹出去 如果不相同就把主队列的栈顶元素弹出来加入a集合 与集合a中其他的元素生成新的b数列的元素 并压入到辅助数列中去 然后重复就ok了

ac代码:

#include<cstdio>
#include<iostream>
#include<queue>
#include<vector>
#include<cstring>
#include<cmath>
using namespace std;
const int N=1e5+10;
int arr[N];
int main()
{
    int m;
    while(scanf("%d",&m)!=EOF)
    {
        priority_queue<int,vector<int>,greater<int> >q1;
        priority_queue<int,vector<int>,greater<int> >q2;
        int n=(-1+(int)sqrt((double)(1+8*m)))/2;
        printf("%d\n",n);
        int a;
        for(int i=0;i<m;i++)
        {
            scanf("%d",&a);
            q1.push(a);
        }
        int cnt=1;
        arr[0]=q1.top(),q1.pop();
        arr[1]=q1.top(),q1.pop();
        q2.push(arr[0]+arr[1]);
        while(!q1.empty())
        {
            while(1)
            {
                if(q1.top()==q2.top())
               {
                q1.pop();
                q2.pop();
               }
               if(q2.empty()==true||q2.top()!=q1.top())
                {
                   cnt++;
                   arr[cnt]=q1.top();
                   q1.pop();
                   break;
                }
            }
            if(cnt==n-1)
                break;
            for(int i=0;i<cnt;i++)
            {
                q2.push(arr[cnt]+arr[i]);
            }
        }
        for(int i=0;i<n;i++)
        {
            if(i==0) printf("%d",arr[i]);
            else printf(" %d",arr[i]);
        }
        printf("\n");
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值