HDU 4371 Alice and Bob

Alice and Bob

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 691    Accepted Submission(s): 420


Problem Description
Alice and Bob are interested in playing games. One day, they invent a game which has rules below:
1. Firstly, Alice and Bob choose some random positive integers, and here we describe them as n, d 1, d 2,..., d m.
2. Then they begin to write numbers alternately. At the first step, Alice has to write a “0”, here we let s 1 = 0 ; Then, at the second step, Bob has to write a number s 2which satisfies the condition that s 2 = s 1 + d k and s 2 <= n, 1<= k <= m ; From the third step, the person who has to write a number in this step must write a number s iwhich satisfies the condition that s i = s i-1 + d k or s i = s i-1 - d k , and s i-2 < s i <= n, 1 <= k <= m, i >= 3 at the same time.
3. The person who can’t write a legal number at his own step firstly lose the game.
Here’s the question, please tell me who will win the game if both Alice and Bob play the game optimally.
 

Input
At the beginning, an integer T indicating the total number of test cases.
Every test case begins with two integers n and m, which are described before. And on the next line are m positive integers d 1, d 2,..., d m.
T <= 100;
1 <= n <= 10 6;
1 <= m <= 100;
1 <= d k <= 10 6, 1 <= k <= m.
 

Output
For every test case, print “Case #k: ” firstly, where k indicates the index of the test case and begins from 1. Then if Alice will win the game, print “Alice”, otherwise “Bob”.
 

Sample Input
  
  
2 7 1 3 7 2 2 6
 

Sample Output
  
  
Case #1: Alice Case #2: Bob
 

两个人轮流写数字,写不出来的那个人就算输了。
因为要是数列处于间隔上升趋势,那么只要每次都选择最小的数字,不给对手做减法的余地



#include <iostream>
#include <stdio.h>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#define N 1000009
using namespace std;

int a[N];
int n,m;
int t;

int main()
{
    while(~scanf("%d",&t))
    {
        for(int ca=1;ca<=t;ca++)
        {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=m;i++)
        scanf("%d",&a[i]);

        sort(a+1,a+1+m);

        int s=0;
        int num=1;
        while(1)
        {
            num++;
            if(s+a[1]>n)
            {
                break;
            }
            s+=a[1];
        }

        printf("Case #%d: ",ca);
        if(num%2==0)
        cout<<"Alice"<<endl;
        else
        cout<<"Bob"<<endl;
        }

    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值