POJ 2799 IP Networks

IP Networks
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2159 Accepted: 815

Description

Alex is administrator of IP networks. His clients have a bunch of individual IP addresses and he decidedto group all those IP addresses into the smallest possible IP network. 

Each IP address is a 4-byte number that is written byte-by-byte in a decimal dot-separated notation "byte0.byte1.byte2.byte3" (quotes are added for clarity). Each byte is written as a decimal number from0 to 255 (inclusive) without extra leading zeroes. 

IP network is described by two 4-byte numbers - network address and network mask. Both networkaddress and network mask are written in the same notation as IP addresses. 

In order to understand the meaning of network address and network mask you have to consider their binary representation. Binary representation of IP address, network address, and network mask consists of 32 bits: 8 bits for byte0 (most significant to least significant), followed by 8 bits for byte1, followed by 8 bits for byte2, and followed by 8 bits for byte3. 

IP network contains a range of 2n IP addresses where 0 <= n <= 32. Network mask always has 32-n first bits set to one, and n last bits set to zero in its binary representation. Network address has arbitrary 32 - n first bits, and n last bits set to zero in its binary representation. IP network contains all IP addresses whose 32-n first bits are equal to 32-n first bits of network address with arbitrary n lastbits. We say that one IP network is smaller than the other IP network if it contains fewer IP addresses. 

For example, IP network with network address 194.85.160.176 and network mask 255.255.255.248 contains 8 IP addresses from 194.85.160.176 to 194.85.160.183 (inclusive).

Input

The first line of the input contains a single integer number m (1 <= m <= 1000). The following m lines contain IP addresses, one address on a line. Each IP address may appear more than once in a case.

Output

Write to the output two lines that describe the smallest possible IP network that contains all IP addresses from this case. Write network address on the first line and network mask on the secondline.

Sample Input

3
194.85.160.177
194.85.160.183
194.85.160.178

Sample Output

194.85.160.176
255.255.255.248

#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#define ll __int64

using namespace std;

int n;
int a,b,c,d;
//告诉N个IP地址求其网络地址及子网掩码
//在同一个网段中,IP地址和子网掩码按位与后等于该网段的网络地址。
int main()
{
    while(~scanf("%d",&n))
    {
        unsigned int maxs = 0;
        unsigned int mins = 0-1;

        unsigned int e;
        for(int i=0;i<n;i++)
        {
            scanf("%d.%d.%d.%d",&a,&b,&c,&d);
            e=(unsigned int)(a<<24)+(b<<16)+(c<<8)+d;

            mins=min(mins,e);
            maxs=max(maxs,e);
        }

        unsigned int mask;//子网掩码
        for(int i=0;i<=32;i++)
        {
            mask=~((1ULL<<i)-1U);//ULL是无符号的长整形,U是无符号整形,防止溢出
            if( (mask&mins)==(mask&maxs))
            break;
        }

        unsigned int ans=(mins&mask);//网络地址

        printf("%u.%u.%u.%u\n",ans>>24,(ans<<8)>>24,(ans<<16)>>24,(ans<<24)>>24);
         printf("%u.%u.%u.%u\n",mask>>24,(mask<<8)>>24,(mask<<16)>>24,(mask<<24)>>24);

    }
    return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值