POJ 2800

Joseph's Problem
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7331 Accepted: 1911

Description

Joseph likes taking part in programming contests. His favorite problem is, of course, Joseph's problem. 

It is stated as follows. 
  • There are n persons numbered from 0 to n - 1 standing in a circle. The person numberk, counting from the person number 0, is executed. After that the person number k of the remaining persons is executed, counting from the person after the last executed one. The process continues until only one person is left. This person is a survivor. The problem is, given n and k detect the survivor's number in the original circle.

Of course, all of you know the way to solve this problem. The solution is very short, all you need is one cycle: 
	r := 0;

	for i from 1 to n do

		r := (r + k) mod i;

	return r;

Here "x mod y" is the remainder of the division of x by y, But Joseph is not very smart. He learned the algorithm, but did not learn the reasoning behind it. Thus he has forgotten the details of the algorithm and remembers the solution just approximately. 

He told his friend Andrew about the problem, but claimed that the solution can be found using the following algorithm: 
	r := 0;

	for i from 1 to n do

		r := r + (k mod i);

	return r;

Of course, Andrew pointed out that Joseph was wrong. But calculating the function Joseph described is also very interesting. 

Given n and k, find  1<=i<=n(k mod i). 

Input

The input file contains n and k (1<= n, k <= 10 9).

Output

Output the sum requested.

Sample Input

5 3

Sample Output

7


当 k >= n 时,应该将商分组,组中的余数是连续的,可以利用等差数列直接求和。比如 k = 36,n = 17 时,分为以下几组:
36/1;
36/2;
36/3;
36/4;
36/5,
36/6;
36/7;
36/8, 36/9;
36/10, 36/11, 36/12;
36/13, 36/14, 36/15, 36/16, 36/17。

#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#define N 1000009
#define ll __int64
using namespace std;
ll n,k;

int main()
{
    while(~scanf("%I64d %I64d",&n,&k))
    {
        ll ans=0;
        if(n>k)
        {
           ans=(k*(n-k));
           n=k;
        }
        ll d;
        d=k/n;

        ll next;
        ll le,ri;

        while(n>1)
        {
           next=k/(d+1);
           if(n==next)//
           {
               //cout<<"d*="<<d<<" "<<"n*="<<n<<" "<<endl;
               ans+=(k%n);
               n--;
               d=k/n;
               continue;
           }
           //cout<<"d="<<d<<" "<<"n="<<n<<" "<<endl;
           le=k%n;
           ri=k%(next+1);
           ans+=(le+ri)*(n-next)/2;
           d++;
           n=next;
        }

        printf("%I64d\n",ans);
    }
    return 0;
}

/*
17 36
d=2 n=17
d=3 n=12
d=4 n=9
d=5 n=7
d=6 n=6
d=7 n=5
d*=8 n*=4
d=12 n=3
d*=13 n*=2
45
*/






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值