poj 1011 sticks 经典剪枝问题

Sticks
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 127727 Accepted: 29912

Description

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

Input

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

Output

The output should contains the smallest possible length of original sticks, one per line.

Sample Input

9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0

Sample Output

6
5

题意:告诉n个小木条,问能组成几个等长的木棍,并且让长度最小。

分析:神剪枝问题,有与没有天壤之别,


#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#define N 100009
using namespace std;

int cmp(int a,int b)
{
    return a>b;
}

int sum,mmin;
int flag;
int n;
int vis[N];
int a[N];
int cnt;
int len;

void dfs(int p,int num,int x)
{
    if(flag) return;
    if(num==cnt)
    {
        flag=1;
        return;
    }

    if(x==len)
        dfs(0,num+1,0);

    for(int i=p;i<n;i++)
    {
        if(vis[i]) continue;
        if( (x+a[i])>len) continue;
        vis[i]=1;
        dfs(i+1,num,x+a[i]);
        vis[i]=0;
        if(flag) return;
        //if(x==0||x+a[i]==len)//神剪枝,有就16毫秒,没有就是TLE
//        return;
//具体理解为
        if(x==0)//如果第一个木棒都没有添加,说明有问题
        return;
        if(x+a[i]==len)//如果现在本来应该成功,应该进入递归变为0,却失败,说明有问题
        return;
    }

}

int main()
{
    while(scanf("%d",&n),n)
    {
         sum=0;
         mmin=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            mmin=max(mmin,a[i]);
            sum+=a[i];
        }

        sort(a,a+n,cmp);
        memset(vis,0,sizeof vis);

        int ans=sum;

        for(len=mmin;len<=sum;len++)
        {
            if(sum%len) continue;
            cnt=sum/len;
            flag=0;
            dfs(0,0,0);
            if(flag)
            {
                ans=len;
                break;
            }
        }

        printf("%d\n",ans);

    }
    return 0;
}







  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值