POJ2240 Arbitrage 最短路 bellmanford

Arbitrage
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18275 Accepted: 7738

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No


告诉一些货币之间兑换的汇率,问是否存在某种兑换方式,使得钱越变越多

我们假设最开始有1单位货币,枚举以每个类型货币为起点,尝试兑换,这个问题可以转化为求是否存在连续乘积大于1的回路,可以直接用bellmanford求解问题


#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;

char name[222][222];
char b[222],a[222];
int n;
int m;
double x;
int flag;
double dis[2222];

struct Node
{
    int u,v;
    double w;
}f[2222];

void bellmanford(int x)
{
    memset(dis,0,sizeof dis);
    dis[x]=1.0;

    for(int i=1;i<=n;i++)//操作n次
    {
        for(int j=1;j<=m;j++)
        {
            dis[f[j].v]=max(dis[f[j].v],dis[f[j].u]*f[j].w);
        }
    }
    if(dis[x]>1.0) flag=1;

}

int main()
{
    int ca=1;
    while(scanf("%d",&n),n)
    {
        for(int i=1;i<=n;i++)
            scanf("%s",name[i]);

        scanf("%d",&m);

        for(int i=1;i<=m;i++)
        {
            scanf("%s %lf %s",a,&x,b);
            int j,k;
            for(j=1; strcmp(a,name[j]); j++)
                ;
            for(k=1; strcmp(b,name[k]); k++)
                ;

            f[i].u=j;
            f[i].v=k;
            f[i].w=x;
        }

        flag=0;
        for(int i=1;i<=n;i++)
        {
            bellmanford(i);
            if(flag) break;
        }

        printf("Case %d: ",ca++);

        if(flag) puts("Yes");
        else puts("No");

    }
    return 0;
}









  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值