hdu-2669(扩展欧几里得)

Problem Description

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.

Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead.
Sample Input
 
  
77 51 10 44 34 79
Sample Output
 
 
2 -3 sorry 7 -3

题目题意十分明显,就是让你求x*a+y*b=1,这个不定方程,x的解有一个条件就是,最小的正整数。

题目分析:扩展欧几里得算法可以解决这样的不定方程x*a+y*b=c,对于这样的一个方程.
我们依据的是最初的方程a*x+b*y=gcd(a,b) ,当c|gcd(a,b)时方程有解。

bool linear_equation(int a,int b,int c,int &x,int &y)
{
    int d=exgcd(a,b,x,y);
    if(c%d)//未满足要求
        return false;
    int k=c/d;
    x*=k; y*=k;    //求得的只是其中一组解
    return true;
}
ax+by=c其他的解满足:
X=x1+b/gcd(a,b)*t;//方程所有的解
Y=y1-a/gcd(a,b)*t;
其中t为任意整数

代码如下:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int gcd(int a,int b)
{
    if (b==0) return a;
    else gcd(b,a%b);
}
int exgcd(int a,int b,int &x,int &y)//解决ax+by=gcd(a,b)
{
    if (b==0) {
        x=1;
        y=0;
        return a;
    }
    int r=exgcd(b,a%b,x,y);
    int t=x;
    x=y;
    y=t-a/b*y;
    return r;
}

bool linear_equation(int a,int b,int c,int &x,int &y)
{
    int d=exgcd(a,b,x,y);
    if (c%d)
        return false;
    int k=c/d;
    x*=k,y*=k;
    int t=0;
    int temp=b/d;
    if (x<0) {//求最小的整数x
        while (x<0) {
            t++;
            x=x+temp*t;
        }
        printf("%d %d\n",x,y-a/d*t);
    }
    else {
        while (x>0) {
            t--;
            x=x+temp*t;
        }
        printf("%d %d\n",x+temp,y-a/d*(t+1));
    }
    return true;
}
int main()
{
    int a,b;
    while (scanf("%d%d",&a,&b)!=EOF) {
        int x,y;
        if (!linear_equation(a,b,1,x,y))
            printf("sorry\n");
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值