HDU 2955 (动态规划-01背包)

问题描述:

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university. 
For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible. 
His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set. 

Notes and Constraints 
0 < T <= 100 
0.0 <= P <= 1.0 
0 < N <= 100 
0 < Mj <= 100 
0.0 <= Pj <= 1.0 
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
Sample Output

2
4
6

题目题意:题目给n个银行的钱数和每个银行的逃跑概率,和自己可以忍受的最大逃跑概率,问最大可以拿到钱数。

题目分析:这个题目和01背包很像,但是有不同。第一概率是浮点数不能像背包容量一样遍历。第二概率的“相加”(俩个银行的概率和)是乘法不是加法。

所以应该换转移方程和状态。我们把dp[i][j]表示在前i个银行拿到钱数为j的逃跑最大概率(1-p)

代码如下:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;

const int maxn=1e4+100;
double dp[110][maxn];
struct note
{
    int v;
    double p;
}bag[110];
int main()
{
    int t;
    scanf("%d",&t);
    while (t--) {
        int n,sum=0;
        double P;
        scanf("%lf%d",&P,&n);
        memset (dp,0,sizeof (dp));
        for (int i=0;i<n;i++) {
            scanf("%d%lf",&bag[i].v,&bag[i].p);
            sum+=bag[i].v;
        }
        for (int i=0;i<=n;i++) {//因为不拿钱的时候,逃跑概率为1
            dp[i][0]=1;
        }
        for (int i=n-1;i>=0;i--) {
            for (int j=1;j<=sum;j++) {
                if (j<bag[i].v) dp[i][j]=dp[i+1][j];
                else dp[i][j]=max(dp[i+1][j],dp[i+1][j-bag[i].v]*(1-bag[i].p));
            }
        }
        for (int i=sum;i>=0;i--) {
            if (dp[0][i]>(1-P)) {//大于最大的逃跑概率就输出
                printf("%d\n",i);
                break;
            }
        }
    }
    return 0;
}









  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值