问题描述:
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000.
The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''.
Output a blank line after each test case.
Sample Input
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0Sample Output
Collection #1: Can't be divided. Collection #2: Can be divided.
题目题意:题目给出了1到6每个数字的个数,问能不能平均分这些数
题目分析:一开始用dp[i][j]表示前面i种数字能否组成数字j,最后T了,得改变状态。
我们用dp[i][j]表示前面i种数字组成数字j,第i种数字还剩几个。
那么有三种状态
num[i+1] if (dp[i][j]>=0)
dp[i+1][j]= -1 if (a<j||dp[i][j-a]<=0)
dp[i][j-a]-1 其他
代码如下:
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
const int maxn=60000+500;
int dp[maxn];
int num[10];
int main()
{
int icase=1;
while (scanf("%d",&num[1])!=EOF) {
int sum=num[1];
for (int i=2;i<=6;i++) {
scanf("%d",&num[i]);
sum+=i*num[i];
}
if (sum==0) break;
memset (dp,-1,sizeof (dp));
if (sum%2==1) {
printf("Collection #%d:\n",icase++);
printf("Can't be divided.\n\n");
continue;
}
dp[0]=0;
for (int i=1;i<=6;i++) {
for (int j=0;j<=sum/2;j++) {
if (dp[j]>=0) dp[j]=num[i];
else if (j<i||dp[j-i]<=0) dp[j]=-1;
else dp[j]=dp[j-i]-1;
}
}
bool flag=false;
if (dp[sum/2]>=0) flag=true;
if (!flag) {
printf("Collection #%d:\n",icase++);
puts("Can't be divided.");
}
else {
printf("Collection #%d:\n",icase++);
puts("Can be divided.");
}
printf("\n");
}
return 0;
}