poj1300 door man

Problem A

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)
Total Submission(s) : 8   Accepted Submission(s) : 5
Problem Description
You are a butler in a large mansion. This mansion has so many rooms that they are merely referred to by number (room 0, 1, 2, 3, etc...). Your master is a particularly absent-minded lout and continually leaves doors open throughout a particular floor of the house. Over the years, you have mastered the art of traveling in a single path through the sloppy rooms and closing the doors behind you. Your biggest problem is determining whether it is possible to find a path through the sloppy rooms where you:

  1. Always shut open doors behind you immediately after passing through
  2. Never open a closed door
  3. End up in your chambers (room 0) with all doors closed

In this problem, you are given a list of rooms and open doors between them (along with a starting room). It is not needed to determine a route, only if one is possible.
 

Input
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.
A single data set has 3 components:

  1. Start line - A single line, "START M N", where M indicates the butler's starting room, and N indicates the number of rooms in the house (1 <= N <= 20).
  2. Room list - A series of N lines. Each line lists, for a single room, every open door that leads to a room of higher number. For example, if room 3 had open doors to rooms 1, 5, and 7, the line for room 3 would read "5 7". The first line in the list represents room 0. The second line represents room 1, and so on until the last line, which represents room (N - 1). It is possible for lines to be empty (in particular, the last line will always be empty since it is the highest numbered room). On each line, the adjacent rooms are always listed in ascending order. It is possible for rooms to be connected by multiple doors!
  3. End line - A single line, "END"

Following the final data set will be a single line, "ENDOFINPUT".

Note that there will be no more than 100 doors in any single data set.
 

Output
For each data set, there will be exactly one line of output. If it is possible for the butler (by following the rules in the introduction) to walk into his chambers and close the final open door behind him, print a line "YES X", where X is the number of doors he closed. Otherwise, print "NO".
 

Sample Input
  
  
START 1 2 1 END START 0 5 1 2 2 3 3 4 4 END START 0 10 1 9 2 3 4 5 6 7 8 9 END ENDOFINPUT
 

Sample Output
  
  
YES 1 NO YES 10
判断图中是否存在欧拉回路,终点规定为0,起点指定。
图为无向图,所以判断方法是如果不存在度数为奇数的节点(房间),并且起点为0则输出YES X。如果存在2个奇数度数的节点,并且分别为0 和 m(m!=0)则存在欧拉回路。其他情况都不符合规定。
这道题比较简单,就是输入要注意使用cin.getline()。
#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;
 int counts[100];
char ch[255];
int m,n,a,b;
int main()
{

    char ch1[255],tp[20];
    while(1)
    {
        cin.getline(ch1,255);
        if(ch1[0]=='S')
        {
            sscanf(ch1,"%s%d%d",tp,&m,&n);
            memset(counts,0,sizeof(counts));
            int x=0,p,temp;

            for(int i=0;i<n;i++)
            {
                cin.getline(ch,255);
                p=0;
                while(sscanf(ch+p,"%d",&temp)==1)
                {
                    x++;
                    counts[i]++;
                    counts[temp]++;
                    while(ch[p]!=0&&ch[p]==' ')
                    {
                        p++;
                    }
                    while(ch[p]!=0&&ch[p]!=' ')
                    {
                        p++;
                    }

                }

            }
             char str[50];
            cin.getline(str,50);
            a=b=0;
            for(int i=0;i<n;i++)
            {
                if(counts[i]%2!=0)
                {
                    a++;
                }
                else
                {
                    b++;
                }
            }
            if(m==0&&a==0)
            {
                printf("YES %d\n",x);
            }
            else if(a==2&&counts[0]%2&&counts[m]%2&&m)
            {
                printf("YES %d\n",x);
            }
            else
            {
                printf("NO\n");
            }

        }
        else
        {
            break;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值