Light OJ1336 Sigma Function

Sigma Function

Description

Sigma function is an interesting function in Number Theory. It is denoted by the Greek letter Sigma (σ). This function actually denotes the sum of all divisors of a number. For example σ(24) = 1+2+3+4+6+8+12+24=60. Sigma of small numbers is easy to find but for large numbers it is very difficult to find in a straight forward way. But mathematicians have discovered a formula to find sigma. If the prime power decomposition of an integer is

Then we can write,

For some n the value of σ(n) is odd and for others it is even. Given a value n, you will have to find how many integers from 1 to n have even value ofσ.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 1012).

Output

For each case, print the case number and the result.

Sample Input

4

3

10

100

1000

Sample Output

Case 1: 1

Case 2: 5

Case 3: 83

Case 4: 947

题意:求[1,n]中约数和为偶数的数的个数

思路:根据算术基本定理的约数和公式f(n)=(1+p1+p1^2+...+p1^k1)(1+p2+p2^2+...+p2^k2)...(1+pn+pn^3+...+pn^kn);

其中n=(p1^k1)*(p2^k2)*...*(pn^kn);(分解素因数)

由于奇数*奇数还是奇数,奇数*偶数或者偶数相乘是偶数。而素数除了2都是奇数。

f(n)的奇偶性取决于每个因子的奇偶性,只要出现一个因子是偶数时f(n)为偶数。

对每个因子,1+p+p^2+...+p^k的奇偶性,

    (1)当p为素数,当p是2时,式子为奇数;

    (2)当p不是2时,p是奇数数,p^i为奇数,式子总共k+1项,即k+1个奇数的和,k为偶数时式子为奇数。

以此条件反推dfs出所有的f(n)为奇数的n,方法是每次乘以奇素数素数的二次方或者2,得到的n就是f(n)为奇数的n了。

n减去奇数的就是所求答案。
#include <cstdio>
#include <iostream>
#include <cstdlib>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <string>
#include <cstring>
#include <stack>
#include <queue>
#include <list>
#include <vector>
#include <map>
#include <set>

using namespace std;

typedef long long LL;
const int INF=0x3f3f3f3f;
const double eps=1e-10;
const double PI=acos(-1.0);

const int maxn=1000100;
LL Max=1e12+100;

LL n;
bool Isnotprime[maxn];
vector<LL>prime;
vector<LL>v;

void find_prime()
{
    for(int i=2;i<maxn;i++)
    {
        if(!Isnotprime[i])
            prime.push_back(i);
        for(int j=0;j<prime.size()&&i*prime[j]<maxn;j++)
        {
            Isnotprime[i*prime[j]]=true;
            if(i%prime[j]==0)
                break;
        }
    }
}

void dfs(int deep,LL now)
{
    v.push_back(now);
    if(deep>=prime.size()) return;
    for(int i=deep;i<prime.size();i++)
    {
        LL tmp=prime[i];
        if(tmp==2)
        {
            if(now<=Max/2)
                dfs(i,now*2);
            else return;
        }
        else
        {
            if(now<=Max/(tmp*tmp))
                dfs(i,now*tmp*tmp);
            else return;
        }
    }
}

int main()
{
    int t;
    int cas=1;
    scanf("%d",&t);
    find_prime();
    dfs(0,1);
    sort(v.begin(),v.end());
    while(t--)
    {
        scanf("%lld",&n);
        LL ans=n-(upper_bound(v.begin(),v.end(),n)-v.begin());
        printf("Case %d: %lld\n",cas++,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值