线段树题型1

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17061    Accepted Submission(s): 8511



Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
  
  
1 10 2 1 5 2 5 9 3
 

Sample Output
  
  
Case 1: The total value of the hook is 24.

题意:

给一组棍子,棍子的初始材质为铜制(价值为1),银制(价值为2),金制(价值为3)执行一系列的改变材质,问这组棍子的总值是多少?

代码:

#include"stdio.h"

#include"string.h"

struct comp

{

    int l,r,mid,x;

}data[400010];

 

void build(int l,int r,int k)//建树

{

    data[k].l=l;

    data[k].r=r;

    data[k].mid=(l+r)/2;

    data[k].x=1;//棍子的初始值为铜制(价值为1)

    if(l==r)

        return;

    build(l,data[k].mid,2*k);

    build(data[k].mid+1,r,2*k+1);

}

void updata(int a, int b,int v,int k)

{

    if(data[k].x==v)//如果需要改变的材质和原来材质一样就直接返回

        return ;

    else if(data[k].l==a&&data[k].r==b)//需要改变的区间等于当前区间,更新价值

        data[k].x=v;

    

    else

    {

if(data[k].x)

data[2*k].x=data[2*k+1].x=data[k].x;//当前价值不为0,把当前价值赋予下一层

data[k].x=0;

if(a>data[k].mid)

updata(a,b,v,2*k+1);

else if(b<=data[k].mid)

updata(a,b,v,2*k);

else

{

updata(a,data[k].mid,v,2*k);

updata(data[k].mid+1,b,v,2*k+1);

}

    }

}

int ans(int l,int r,int k)

{

    int sum=0;

    if(data[k].x)

        sum+=data[k].x*(data[k].r-data[k].l+1);//如果当前价值不为0,说明该区间内每个棍子价值相同,总价值为  价值*区间长度

    else

    {

        sum+=ans(l,data[k].mid,2*k);

        sum+=ans(data[k].mid+1,r,2*k+1);

    }

    return sum;

}

int main()

{

    int T,n,q,a,b,c,i,t;

    scanf("%d",&T);

    for(t=1;t<=T;t++)

    {

        scanf("%d",&n);

        build(1,n,1);

        scanf("%d",&q);

        for(i=1;i<=q;i++)

        {

            scanf("%d%d%d",&a,&b,&c);

            updata(a,b,c,1);

        }

        printf("Case %d: The total value of the hook is %d.\n",t,ans(1,n,1));

    }

    return 0;

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值