ones

ones

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
Given a positive integer N (0<=N<=10000), you are to find an expression equals to N using only 1,+,*,(,). 1 should not appear continuously, i.e. 11+1 is not allowed.
输入
There are multiple test cases. Each case contains only one line containing a integer N
输出
For each case, output the minimal number of 1s you need to get N.
样例输入
2
10
样例输出
2
7

分析:就是一个简单的dp,但刚开始想的有些简单想对n开根号一步步求取,发现有好多bug,,

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define M 10005
int dp[M] = {0,1,2,3};
int main()
{
    int n;
    for(int i = 3; i < M; i++)
    {
        dp[i] = dp[i-1] + 1;
        for(int k = 2; k*k <= i; k++)
        {
            if(0 == i%k)
            {
                dp[i] = min(dp[i], dp[i/k]+dp[k]);
            }
        }
    }


    while(cin>>n)
    {
        cout<<dp[n]<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值