PAT 1001 A+B Format (20分) to_string()

52 篇文章 0 订阅

题目

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤10​6​​ . The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
-1000000 9
Sample Output:
-999,991

题目解析

给出两个数字(-10000001000000之间),计算他们的和,以标准格式输出(形如 99,999,999

  • 首先,两个数都是-10000001000000之间,所以直接用int保存求和即可,不会溢出

  • 然后为了输出方便,将其转为字符串,(to_string()是c++11引入的新方法)

  • 从前往后逐个输出字符,如果是负数,第一个字符是 '-'

  • 什么时候要输出 ',' ,标准格式是从后往前三个一输出,假设转成字符串后的长度为len,那么 len % 3 就是最前面多出的长度,也就是第一个 ',' 出现的位置,后面的都可以三个一组,就隔三个,输出一个 ','

    比如 12,345,666len = 8len % 3 = 2,所以第2个数字后面加 ','第5个数字后面加 ‘,’,第 8 个数字后加 ‘,’,但是第8个是最后一个数字,所以要排除。所以 条件就是 i % 3 == len % 3,但是因为我们的下标是从0开始的,而我们是数数字个数判断,所以应该是 (i + 1) % 3 == len % 3 && (i != len % 3)

代码

#include <iostream>
using namespace std;
int main() {
  int a, b;
  cin >> a >> b;
  // 两数和转为字符串
  string s = to_string(a + b);
  // 得到有效长度
  int len = s.length();
  for (int i = 0; i < len; i++) {
    // 输出当前位
    cout << s[i];
    if (s[i] == '-')
      continue;
    // 标准化格式 -xx,123,999
    if ((i + 1) % 3 == len % 3 && i != len - 1)
      cout << ",";
  }
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值