题目
Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.
Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.
Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.
Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO
解析
题目:
有一个栈,大小为M
,有N
个数字,数字1~N
只能按顺序依次入栈。给出K
个出栈序列,判断该序列是否是可以实现的出栈序列。
思路:
- 入栈顺序是确定的(
1-N
依次入栈),我们只需要模拟这个过程。 - 先把输入的序列接收进数组
seq[]
,设index= 1
,表示当前比较的是序列哪个元素,然后按顺序1~n
把数字进栈,每进入一个数字,判断有没有超过栈容量m
,超过了就break
。 - 如果没超过,看看当前序列元素
seq[index]
是否与栈顶元素s.top()
相等:while
相等就一直弹出栈s.pop()
,index++
,相当于当前序列元素匹配成功,继续处理下一个;不相等就继续按顺序把数字压入栈。若能完美模拟,最终栈应该是空的,说明这个序列是可能的,输出YES
代码
#include <iostream>
#include <stack>
#include <vector>
using namespace std;
int main() {
// 栈容量m,序列长度n,k个序列
int m, n, k;
cin >> m >> n >> k;
while (k -- > 0) {
vector<int> seq(n + 1);
stack<int> s;
// 序列哪个位置元素
int index = 1;
// 输入这个序列
for (int j = 1; j <= n; ++j) cin >> seq[j];
// 模拟入栈过程(只能从1到n入栈)
for (int j = 1; j <= n; ++j) {
s.push(j);
// 栈中元素不能超过m个
if (s.size() > m) break;
// 如果当前栈顶元素和当前序列元素相等
while (!s.empty() && s.top() == seq[index]) {
// 出栈,相当于成功匹配这个元素
s.pop();
// 处理序列下一个元素
index++;
}
}
// 如果最终栈空,说明这个序列可以是正确的出栈序列
if (s.empty()) cout << "YES" << endl;
else cout << "NO" << endl;
}
return 0;
}