7-1 根据后序和中序遍历输出先序遍历 (8 point(s))
本题要求根据给定的一棵二叉树的后序遍历和中序遍历结果,输出该树的先序遍历结果。
输入格式:
第一行给出正整数N(≤30),是树中结点的个数。随后两行,每行给出N个整数,分别对应后序遍历和中序遍历结果,数字间以空格分隔。题目保证输入正确对应一棵二叉树。
输出格式:
在一行中输出Preorder:
以及该树的先序遍历结果。数字间有1个空格,行末不得有多余空格。
输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
输出样例:
Preorder: 4 1 3 2 6 5 7
#include <stdio.h>
#include <stdlib.h>
#include<iostream>
using namespace std;
typedef char ElementType;
typedef struct TNode *Position;
typedef Position BinTree;
struct TNode
{
ElementType Data;
BinTree Left;
BinTree Right;
};
BinTree build(int n, int *mid, int *post);
void PreorderPrintLeaves(BinTree BT);
int main()
{
int mid[100];
int post[100];
int i = 0, n;
cin >> n;
for (int i = 0; i < n; i++)
{
cin >> post[i];
}
for (int i = 0; i < n; i++)
{
cin >> mid[i];
}
BinTree BT = NULL;
BT = build(n, mid, post);
printf("Preorder:");
PreorderPrintLeaves(BT);
}
BinTree build(int n, int *mid, int *post)
{
BinTree temp;
if (n <= 0)
return NULL;
temp = (TNode *)malloc(sizeof(struct TNode));
temp->Data = post[n - 1];
temp->Left = NULL;
temp->Right = NULL;
int i = 0;
while (post[n - 1] != mid[i])
i++;
temp->Left = build(i, mid, post); // 递归建立左子数
temp->Right = build(n - 1 - i, mid + i + 1, post + i);// 递归建立右子数
return temp;
}
int flag = 1;
void PreorderPrintLeaves(BinTree BT)
{
if (BT == NULL)
{
return;
}
printf(" %d", BT->Data);
if (BT->Left)
PreorderPrintLeaves(BT->Left);
if (BT->Right)
PreorderPrintLeaves(BT->Right);
}