C++ DFS练习 拯救007

06-图2 Saving James Bond - Easy Version (25 point(s))

This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape -- he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head... Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:

For each test case, print in a line "Yes" if James can escape, or "No" if not.

Sample Input 1:

14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12

Sample Output 1:

Yes

Sample Input 2:

4 13
-12 12
12 12
-12 -12
12 -12

Sample Output 2:

No

 

这里用一个vector存储所有第一步能跳的点,并对所有能跳的点进行DFS,如果跳到岸边就停止输出答案,为了做OJ做题方便,点的存储以及点的个数,还有能跳的最大距离,都用全局变量。存储的是点的编号

#include<iostream>
#include<cmath>
#include<vector>
#define MAX_NUM 110
struct coordinate
{
	int x;
	int y;
	coordinate(int x_, int y_):x(x_),y(y_){}
	coordinate(){}
}P[MAX_NUM];

int n;                                          // 点的总个数
int d;                                          // 跳的距离
bool visited[MAX_NUM];
void init();
double Distance(coordinate &a, coordinate &b);  // 求a和b点的距离
void DFS(int i);                                // 从编号为i点开始深搜

int main()
{
	coordinate Origin(0, 0);
	std::vector<int> FirstJump;                 // 记录第一个能跳点的标号
	scanf("%d %d", &n, &d);
	for (int i = 0; i < n; i++){
		scanf("%d %d", &P[i].x, &P[i].y);
		if (Distance(P[i], Origin) <= (d + 7.5))
			FirstJump.push_back(i);
	}

	if (FirstJump.size() == 0) {
		printf("No\n");
		return 0;
	}

	for (int i = 0; i < FirstJump.size(); i++){
		init();
		DFS(FirstJump[i]);
	}

	printf("No\n");
	return 0;

}

double Distance(coordinate &a, coordinate &b)
{
	return sqrt(pow((a.x - b.x), 2) + pow((a.y - b.y), 2));
}


void DFS(int i)
{
	visited[i] = true;
	if ((50 - abs(P[i].x)) <= d || (50 - abs(P[i].y)) <= d){
		printf("Yes\n");
		exit(0);
	}
	for (int j = 0; j < n; j++){
		if (!visited[j] && Distance(P[i], P[j]) <= d){
			DFS(j);
		}
	}
}

void init() {
	for (int i = 0; i < n; i++) {
		visited[i] = false;
	}
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值