题目描述
我们规定对一个字符串的shift操作如下:
shift(“ABCD”, 0) = “ABCD”
shift(“ABCD”, 1) = “BCDA”
shift(“ABCD”, 2) = “CDAB”
换言之, 我们把最左侧的N个字符剪切下来, 按序附加到了右侧。
给定一个长度为n的字符串,我们规定最多可以进行n次向左的循环shift操作。如果shift(string, x) = string (0<= x <n), 我们称其为一次匹配(match)。求在shift过程中出现匹配的次数。
输入
输入仅包括一个给定的字符串,只包含大小写字符。
| 样例输入
byebyebye
|
输出
输出仅包括一行,即所求的匹配次数。
| 样例输出
3
|
时间限制C/C++语言:1000MS其它语言:3000MS | 内存限制C/C++语言:65536KB其它语言:589824KB |
容易推出
len = len(str)
shift(str, x) = str[len-x:len] + str[x:len]
这一步操作可以原地完成,也可以借助辅助空间完成,时间复杂度均为O(N), 严格来说使用额外空间的在时间上更快些。
容易推出x的取值范围只会是1到len-1。
所以很容易想到一个O(N^2)的做法
#include<iostream>
#include<string>
using namespace std;
string shiftn(string s, int n)
{
//string temp = s + s;
//return temp.substr(n, s.size());
return s.substr(s.size() - n, n) + s.substr(n, s.size() - n);
}
int main()
{
string s;
cin >> s;
int count = 0;
for (int i = 0; i < s.size(); i++)
{
if (s == shiftn(s, i))
count++;
}
cout << count << endl;
return 0;
}
很容易想到,这个问题可以转化为求字符串的最小周期。
这个可以用KMP的next数组在O(N)的时间解决。
#include<iostream>
#include<string>
using namespace std;
const int N = 1000010;
int Next[N];
void getnext(string& s)
{
int j = -1;
Next[0] = -1;
for (int i = 1; i < s.size(); i++)
{
while (j > -1 && s[j + 1] != s[i]) j = Next[j];
if (s[j + 1] == s[i]) j++;
Next[i] = j;
}
}
int main()
{
string s;
cin >> s;
getnext(s); // 计算next数组
int n = s.size();
int t = Next[n - 1] + 1;
if (n % (n - t) == 0)
printf("%d\n", n / (n - t));
else printf("%d\n", 1);
}