HDU 【1022】Train Problem I

Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
 

Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 

Output
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 

Sample Input
  
  
3 123 321 3 123 312
 

Sample Output
  
  
Yes. in in in out out out FINISH No. FINISH
Hint
Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".
怎么说,这道题一开始我想用最简单的字符串处理方法做的,当然,结果也确实是我想的太简单了,根本不是让那样做的,因为存在一种情况是:可能列车会进轨道不止一次,也就是说,如果输入5 12345 21543,这组数据也是Yes,它的意思就是1和2是第一批进去的,出来也是按着栈的形式出的,而后面第二批也是按着栈的形式进出的,所以数据也是对的,这种情况就导致了我想的太简单了,QAQ,所以我还是用了今天刚学的栈来做的,这道题其实也确实是栈的简单运用,先进后出,不过这道题要注意的是要把每趟已经出去的列车给排除掉,如果都出去的话,队列为空,只有队列最后为空的话才可以输出Yes,否则输出No,代码如下,挺简单的(好吧,开始的时候不想加注释的,但发现不是那种一看就会的,为了方便,就加上注释了):

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<vector>
#include<stack>
#include<queue>
#include<algorithm>
using namespace std;
int main()
{
	int n,i,k,c[3005],t;
	char a[1005],b[1005];
	while(scanf("%d",&n)!=EOF)
	{
		stack<char > q;//这里加一个栈就是为了后面的比较
		scanf("%s%s",a,b);
		k=t=0;
		for(i=0;i<n;i++)
		{
			q.push(a[i]);
			c[t++]=1;//一个标记,用来标记进出的,具体用法也不好表示,所以看代码,自行体会
			while(!q.empty()){//记住这里,这里比较不容易理解,这里意思是,前面不是吧a的数据挨个都放入栈里了吗,这个操作就是在栈里面进行的操作。
				char x=q.top();//x等于每次栈里面的第一个,如果这个数字和b(也就是设置的出栈顺序)里面的数字相同的话意味着它该出栈了,用c[t]=2来标记一下,其实总的来说这里还是得自己体会一下,不是很好表达啥意思
				if(x==b[k]){
					c[t++]=2;
					k++;
					q.pop();
				}
				else//这里就是一个否定点,意思是栈没有出完就结束了,根据下面语句,这种情况就是不可能的情况了
				break;
			}
		}
		if(!q.empty())
		printf("No.\nFINISH\n");
		else{
			printf("Yes.\n");
			for(int i=0;i<t;i++)//这里就是根据标记来判断进出了,也是这道题我一开始弄错的地方
			if(c[i]==1)
			printf("in\n");
			else
			printf("out\n");
			printf("FINISH\n");
		}
	}
return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值