不是oj上的题。。我就不贴链接了
用STL的list做的这个题,感觉有了STL,天黑都不怕了。
设计函数求一元多项式的导数。
输入格式:以指数递降方式输入多项式非零项系数和指数(绝对值均为不超过1000的整数)。数字间以空格分隔。
输出格式:以与输入相同的格式输出导数多项式非零项的系数和指数。数字间以空格分隔,但结尾不能有多余空格。注意“零多项式”的指数和系数都是0,但是表示为“0 0”。
输入样例:3 4 -5 2 6 1 -2 0输出样例:
12 3 -10 1 6 0
#include<iostream>
#include<list>
#include<stdio.h>
using namespace std;
struct Node{
int value;
int x;
};
void Scan_list(int value,int x,list<Node> *l)
{
Node n;
n.value=value;
n.x=x;
l->push_back(n);
}
void Cal_list(list<Node> *l,list<Node> *re)
{
list<Node>::iterator p=l->begin();
Node n;
for(p ; p!=l->end() ; p++){
if(p->x != 0) {
n.value = p->value * p->x;
n.x = p->x - 1;
re->push_back(n);
}
}
}
void Print_list(list<Node> *re)
{
list<Node>::iterator p=re->begin();
list<Node>::iterator q=re->end();
q--;
bool sign=0;
for(p ; p!=re->end() ; p++){
if(p->value){
sign=1;
printf("%d %d",p->value,p->x);
if(p != q) printf(" ");
}
}
if(!sign){
printf("0 0");
}
}
int main()
{
list<Node> l;
list<Node> re;
int x1,x2;
while(scanf("%d %d",&x1,&x2)!=EOF)
Scan_list(x1,x2,&l);
Cal_list(&l,&re);
Print_list(&re);
return 0;
}