【POJ】2406 - Power Strings(KMP)

点击打开题目

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 43751 Accepted: 18257

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source




用KMP算法求出next数组后,找到最后一个0的位置,这个就是最短的数结束循环的位置。然后输出 l / (endd + 1) 然后就光荣的wa了。

原因是没有考虑特殊情况,例子:ABABA,输出应该是1,但是按上面的会输出2。所以我们还要判断一下 l 是否能整除 (endd + 1) ,如果不能就输出1。


代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define CLR(a,b) memset(a,b,sizeof(a))
#define INF 0x3f3f3f3f
#define LL long long
#define MAX 1000000
char T[MAX+11];
int next[MAX+11];
void makeNext()
{
	next[0] = 0;
	int l = strlen(T);
	int endd = 0;
	int k = 0;
	for (int i = 1 ; i < l ; i++)
	{
		while (k > 0 && T[i] != T[k])
			k = next[k-1];
		if (T[k] == T[i])
			k++;
		next[i] = k;
		if (next[i] == 0)
			endd = i;
	}
	printf ("%d\n",(l % (endd+1) == 0) ? (l / (endd+1)) : 1);
}
int main()
{
	while (~scanf ("%s",T))
	{
		if (T[0] == '.')
			break;
		makeNext();
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值