Problem D. Euler Function
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 138 Accepted Submission(s): 124
Problem Description
In number theory, Euler's totient function φ(n) counts the positive integers up to a given integer n that are relatively prime to n. It can be defined more formally as the number of integers k in the range 1≤k≤n for which the greatest common divisor gcd(n,k) is equal to 1.
For example, φ(9)=6 because 1,2,4,5,7 and 8 are coprime with 9. As another example, φ(1)=1 since for n=1 the only integer in the range from 1 to n is 1itself, and gcd(1,1)=1.
A composite number is a positive integer that can be formed by multiplying together two smaller positive integers. Equivalently, it is a positive integer that has at least one divisor other than 1 and itself. So obviously 1 and all prime numbers are not composite number.
In this problem, given integer k, your task is to find the k-th smallest positive integer n, that φ(n) is a composite number.
Input
The first line of the input contains an integer T(1≤T≤100000), denoting the number of test cases.
In each test case, there is only one integer k(1≤k≤109).
Output
For each test case, print a single line containing an integer, denoting the answer.
Sample Input
2 1 2
Sample Output
5 7
Source
2018 Multi-University Training Contest 3
打了个表,发现除了1 2 3 4 6 不符合条件,其他都是
#include <bits/stdc++.h>
#define fir first
#define se second
#define mp make_pair
#define pb push_back
#define ll long long
using namespace std;
const int maxn=3000+10;
const ll mod=998244353;
const double eps=1e-7;
const int maxm=1e6+10;
const int inf=0x3f3f3f3f;
int phi(int x){
int res=x;
for (int i=2;i*i<=x;i++){
if (x%i==0){
while (x%i==0) x/=i;
res/=i;
res*=(i-1);
}
}
if (x>1){
res/=x;
res*=(x-1);
}
return res;
}
int check(int x){
int res=phi(x);
for (int i=2;i<res;i++){
if(res%i==0)
return 1;
}
return 0;
}
int ans[5]={5,7,8,9,10};
int main(){
int t;
scanf("%d",&t);
while (t--){
int k;
scanf("%d",&k);
if (k<=5){
printf("%d\n",ans[k-1]);
continue;
}
else{
int dif=(k-5)+10;
printf("%d\n",dif);
}
}
return 0;
}