Magic Square

In recreational mathematics, a magic square of n-degree is an arrangement of n 2 numbers, distinct integers, in a square, such that the n numbers in all rows, all columns, and both diagonals sum to the same constant. For example, the picture below shows a 3-degree magic square using the integers of 1 to 9.

 

Given a finished number square, we need you to judge whether it is a magic square.

 

 

Input

 

The input contains multiple test cases.

The first line of each case stands an only integer N (0 < N < 10), indicating the degree of the number square and then N lines follows, with N positive integers in each line to describe the number square. All the numbers in the input do not exceed 1000.

A case with N = 0 denotes the end of input, which should not be processed.

 

 

Output

 

For each test case, print "Yes" if it's a magic square in a single line, otherwise print "No".

 

 

Sample Input

 

2
1 2
3 4
2
4 4
4 4
3
8 1 6
3 5 7
4 9 2
4
16 9 6 3
5 4 15 10
11 14 1 8
2 7 12 13
0

 

 

Sample Output

 

No
No
Yes
Yes
#include"cstdio"
#include"iostream"
#include"cstring"
#include"algorithm"
using namespace std;
int main()
{
	int n , xx[11][11] , yy[31] , zz[1002];
	while(cin>>n,n)
	{
		memset(xx,0,sizeof(xx));
		memset(yy,0,sizeof(yy));
		memset(zz,0,sizeof(zz));
		int a = 0 , b = 0 , c = 0 , d = 0;
		for(int i = 0 ; i < n ; i ++)
		{
			for(int j = 0 ; j < n ; j ++)
			{
				cin>>xx[i][j];
				if(i == j)
					a += xx[i][j];
				if(i + j == n - 1)
					b += xx[i][j];
				yy[i] += xx[i][j];
				yy[j + n] += xx[i][j];
				zz[xx[i][j]]++;
			}
		}
		for(int i = 1 ; i <= 1000 ; i ++)
		{
			if(zz[i] > 1)
			{
				d = 1;
				cout<<"No"<<endl;
				break;
			}
		}
		if(d == 1)
			continue;
		yy[2 * n] = a;
		yy[2 * n + 1] = b;
		for(int i = 1 ; i < 2 * n + 2 ; i ++)
		{
			//cout<<yy[i]<<" ";
			if(yy[i] != yy[i-1])
			{
				cout<<"No"<<endl;
				break;
			}
			c++;
		} 
		if(c == 2 * n + 1)
			cout<<"Yes"<<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值