1010. 一元多项式求导 (25)

1010. 一元多项式求导 (25)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
8000 B
判题程序
Standard

设计函数求一元多项式的导数。

输入格式:以指数递降方式输入多项式非零项系数和指数(绝对值均为不超过1000的整数)。数字间以空格分隔。

输出格式:以与输入相同的格式输出导数多项式非零项的系数和指数。数字间以空格分隔,但结尾不能有多余空格。

输入样例:
3 4 -5 2 6 1 -2 0
输出样例:
12 3 -10 1 6 0


#include <iostream>

using namespace std;

int main()
{
	int input;
	int inex;
	int output;
	int outex;
	bool flag = false;

	while(cin>>input>>inex)
	{
		output = input * inex;
		outex = inex -1;
		if(0 != output)
		{
			if(flag)
			{
				cout<<" ";
			}
			else
			{
				flag = true;
			}
			cout<<output<<" "<<outex;
		}
	}
	if(false == flag)
	{
		cout<<"0 0";
	}
	cout<<endl;

	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值