POJ_1007 DNA Sorting

DNA Sorting
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 72977 Accepted: 29150

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA


大概题意,就是每个序列中,统计出非顺序数,既对应字母后面比它大的字母个数的总和,比如 DAABEC  = 4(D---AABC) + 1(E---C) = 5 ,一开始理解题目有点出入,卡了一阵子,最后发现原来是水题...

思路:对每个字母统计出后面出现的字母比它大的字母个数的总和,再进行排序,最后输出最大的哪个字符串。

具体代码如下:

#include<iostream>
#include<string>
using namespace std;
struct dna
{
	string str;
	int num;
};

struct dna tmp,dn[105];
int main()
{
	int n,m,i,j,k;
	cin >> n >> m;
	for(i = 1; i <= m; i++)
	{
		cin >> dn[i].str;
		//计算逆序数
		dn[i].num = 0;
		j = 0;
		while(j < n - 1)
		{
			while(j < n && dn[i].str[j] == 'A' )
				j++;
			for(k = j + 1; k < n; k++)
				if(dn[i].str[j] > dn[i].str[k])
					dn[i].num++;
			j++;			
		}

	}

	//对dn的num进行排序
	for(i = 1; i < m; i++)
		for(j = i + 1; j <= m; j++)
		{
			if(dn[i].num > dn[j].num)
			{
				tmp.num = dn[i].num;
				tmp.str = dn[i].str;
				dn[i].num = dn[j].num;
				dn[i].str = dn[j].str;
				dn[j].num = tmp.num;
				dn[j].str = tmp.str;
			}
		}
	//输出排序后的dn的str
	for(i = 1; i <= m; i++)
		cout << dn[i].str << endl;


	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值