Prime Ring Problem

14 篇文章 0 订阅

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

题意:经典题目素数环。相邻两个数字之间互质,输入数字n,输出所有符合要求序列(无重复)。

#include<iostream>
using namespace std;
int m;
int a[20]={0};
int visit[20]={0};
int prime(int n){///素数
    int i;
    for(i=2;i<n/2+1;i++){
        if(n%i==0){
            break;
        }
    }
    if(i>=n/2+1&&n>1)return 1;
    else return 0;
}
void dfs(int cnt){///深搜
    int i;
    if(prime(a[0]+a[m-1])==1&&cnt==m){
        cout<<a[0];
        for(i=1;i<m;i++)
            cout<<' '<<a[i];
        cout<<endl;
    }else for(i=2;i<=m;i++){
        if(!visit[i]&&prime(i+a[cnt-1])){
            a[cnt]=i;
            visit[i]=1;
            dfs(cnt+1);
            visit[i]=0;
        }
    }
    
}



int main(){
    int i;
    int count=0;
    while(cin>>m){
        for(i=0;i<m;i++){
            a[i]=i+1;
        }
        count++;
        cout<<"Case "<<count<<":"<<endl;
        dfs(1);
        cout<<endl;
        
        
    }
    
    
    
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值