Train Problem I

34 篇文章 0 订阅

Problem Description

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.

Input

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.

Output

The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

Sample Input

3 123 321
3 123 312

Sample Output

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

Hint

 

For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output "No.".

题意及分析:给出一个类似于栈的火车站,再给出一组火车进站顺序和一组火车出站顺序,问火车能否以给定出站顺序出站,若能,则给出进出站过程;若不能,则输出no。根据题意,使用栈实现,我们先假设火车能按照给定顺序出站,设置记录进站出站数组vis[],进站记1,出站记0;我们按照顺序依次进栈,每次进栈之后都比较栈顶元素与出站火车顺序数组当前元素值是否相等,是则进栈之后跟着出栈,不是则继续进栈。如果最后出站顺序数组当前指针没指到外面去,则说明不能按照给定顺序出站,否则可以,根据vis[]打印in和out。例进站123,出站321。进站1,出站指向3,比较:1!=3;继续进站2,比较2!=3;继续进栈3,比较3==3,出站指针后移,指向2,栈中3出栈;当前栈顶2,比较2==2,出站指针后移,指向1,栈中2出栈;当前栈顶1,比较1==1;出站指针后移,指向空,栈中1出栈。比较结束,符合要求,输出yes。

#include<iostream>
#include<cstdio>
#include<stack>
#include<cstring>
using namespace std;
int main(){
      stack<char>zhan;///
      char s[20];///进站顺序
      char sp[20];///出站顺序
      int n;
      while(~scanf("%d %s %s",&n,&s,&sp)){
            int vis[20];///输出专用数组
            while(!zhan.empty()){
                  zhan.pop();
            }
            int i=0,j=0,k=0;///k为输出专用数组下标标记
            while(i<=n&&j<n){
                  if(zhan.empty()||zhan.top()!=sp[j]){//如果栈顶和当前出站首位不一致,
                                                      //则当前进站火车进栈。
                        zhan.push(s[i]);
                        vis[k]=1;
                        i++;
                        ///进站指针标记,跑到n+1说明当最后一辆火车进栈的时候都没有和
                        ///当前出站首位匹配,即不能满足出站顺序
                  }else{
                        zhan.pop();
                        vis[k]=0;
                        j++;///出站顺序首位标记
                  }
                  k++;
            }
            if(i==n+1){
                  cout<<"No."<<endl;

            }else{
                  cout<<"Yes."<<endl;
                  for(i=0;i<k;i++){
                        if(vis[i]==1)cout<<"in"<<endl;
                        else cout<<"out"<<endl;
                  }
            }
            cout<<"FINISH"<<endl;
      }




return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值