ACM--steps--2.1.4--素数筛选

Largest prime factor

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4866 Accepted Submission(s): 1450
Problem Description
Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.
 

Input
Each line will contain one integer n(0 < n < 1000000).
 

Output
Output the LPF(n).
 

Sample Input
1
2
3
4
5
 

Sample Output
0
1
2
1
3
 

Author
Wiskey
 

Source
HDU 2007-11 Programming Contest_WarmUp
 

Recommend
威士忌

问一个数的最大素因子是第几个素数。
算术基本定理:   任何大于1的正整数n可以唯一表示成有限个素数的乘积

值得注意的是,试了n遍,输入输出必须用scanf和printf不然,TIME LIMIT EXCEEDED
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int N=1000005;
int wyx[N];
int main()
{
    //进行类似于打表的计算。
    memset(wyx,0,sizeof(wyx));
    int i,j;
    int k=0;
    for(i=2;i<N;i++)
    {
        if(!(wyx[i]))//确定每个数字只会出现一次。
        {//因为每个合数都可以分解成为两个其他数字的乘积。例如6=2*3;
        k++;//k表示的是位置。
        //接下来进行类似于打表的操作。
        for(j=i;j<N;j+=i)
        {
            wyx[j]=k;
        }
        }
    }
    int n;
    while(scanf("%d",&n)!=EOF)
    {
      printf("%d\n",wyx[n]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值