ACM--steps--2.2.6--找规律

Number Sequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1384 Accepted Submission(s): 542
 
Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 
Output
For each test case, print the value of f(n) on a single line.
 
Sample Input
1 1 3
1 2 10
0 0 0
 
Sample Output
2
5
 
Author
CHEN, Shunbao
 
Source
ZJCPC2004

先贴自己的代码。。身为数学系的学生,我深切感到我的数学都学到猪身上了。再见
第二个代码是转的出自http://kgdvoso.lofter.com/post/cafef_31acc6,竟然把所有的周期都算出来然后求其公约数,惊恐
#include<iostream>
using namespace std;
const int N=100000001;
int dyx[N];
int main()
{
    int a,b,n,i,j;
    int wyx;//记录循环周期。
    dyx[1]=1;
    dyx[2]=1;
    while(cin>>a>>b>>n)
    {
        if(a==0&&b==0&&n==0)
        break;
        //看了一下是有循环周期的,看了一下网上的题解,要注意循环节是会随着a&b的变化而产生变化的。
        wyx=0;
        //最大周期为49;
        for(i=3;i<=n;i++)
        {
            dyx[i]=(a*dyx[i-1]+b*dyx[i-2])%7;
            for(j=2;j<i;j++)
                if(dyx[i-1]==dyx[j-1]&&dyx[i]==dyx[j])
                {
                   wyx=i-j;
                   break;
                }
            if(wyx>0)
            //如果进行循环的话
            break;
        }
        if(wyx>0)
        dyx[n]=dyx[(n-j)%wyx+j];
        cout<<dyx[n]<<endl;
    }
    return 0;
}

转的方法。。。

#include<stdio.h>
#include<string.h>
int main()
{
    int a,b,n,i;
    while(1)
    {
        scanf("%d%d%d",&a,&b,&n);
        if(a==0&&b==0&&n==0)
            break;
        int f[1009];
        f[1]=1;
        f[2]=1;
        for(i=3;i<=1008;i++)
        {

            f[i]=(a*f[i-1]+b*f[i-2])%7;


        }
        printf("%d\n",f[(n-1)%1008+1]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值