ACM--steps-3.2.5--Monkey and Banana//动态规划的最大子列和

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 721 Accepted Submission(s): 455
 
Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 
Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 
Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
 
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342
 
 
Source
University of Ulm Local Contest 1996
 
Recommend
JGShining

#include<iostream>
#include<algorithm>
using namespace std;
struct zr
{
    int x,y,hei;
    int wyx;//表示以某一状态为底的砖块可以搭建的最大高度。
}dyx[200];//因为数据最大为30组,下面分析最复杂一组有6种情况。
//用sort函数给砖块排序,以底面积为升序排列
bool cmp(zr a,zr b)
{
    if(a.x<b.x)
    return 1;
    if(a.x==b.x&&a.y<b.y)
    return 1;
    else return 0;
}
int main()
{
    int n; 
    int Ti=0;
    while(cin>>n&&n)
    {
        int k=0;
       
        Ti++;
        int x,y,z;
        while(n--)
        {
            cin>>x>>y>>z;
            //分情况讨论砖块放置的高度。
            //砖块的长宽高是可以相互转换的。
            if(x==y)
            {
                if(y==z)//如果x,y,z都相等的话。
                {
                    dyx[k].x=x;
                    dyx[k].y=y;
                    dyx[k].hei=z;//都相等只有一种情况。
                    dyx[k].wyx=dyx[k].hei;
                    k++;
                }
                else if(y!=z)//x==y!=z
                {
                    dyx[k].x=x;dyx[k].y=x;dyx[k].hei=z;dyx[k].wyx=dyx[k].hei;k++;
                    dyx[k].x=z;dyx[k].y=x;dyx[k].hei=x;dyx[k].wyx=dyx[k].hei;k++;
                    dyx[k].x=x;dyx[k].y=z;dyx[k].hei=x;dyx[k].wyx=dyx[k].hei;k++;
                }
            }
            else//x!=y;
            {
                if(y==z)//x!=y==z
                {
                    dyx[k].x=x;dyx[k].y=z;dyx[k].hei=z;dyx[k].wyx=dyx[k].hei;k++;
                    dyx[k].x=z;dyx[k].y=z;dyx[k].hei=x;dyx[k].wyx=dyx[k].hei;k++;
                    dyx[k].x=z;dyx[k].y=x;dyx[k].hei=z;dyx[k].wyx=dyx[k].hei;k++;
                }
                else if(x==z)//x==z!=y
                {
                    dyx[k].x=y;dyx[k].y=x;dyx[k].hei=x;dyx[k].wyx=dyx[k].hei;k++;
                    dyx[k].x=x;dyx[k].y=y;dyx[k].hei=x;dyx[k].wyx=dyx[k].hei;k++;
                    dyx[k].x=x;dyx[k].y=x;dyx[k].hei=y;dyx[k].wyx=dyx[k].hei;k++;
                }
                else//x!=y!=z
                {
                    dyx[k].x=x;dyx[k].y=y;dyx[k].hei=z;dyx[k].wyx=dyx[k].hei;k++;
                    dyx[k].x=x;dyx[k].y=z;dyx[k].hei=y;dyx[k].wyx=dyx[k].hei;k++;
                    dyx[k].x=y;dyx[k].y=x;dyx[k].hei=z;dyx[k].wyx=dyx[k].hei;k++;
                    dyx[k].x=y;dyx[k].y=z;dyx[k].hei=x;dyx[k].wyx=dyx[k].hei;k++;
                    dyx[k].x=z;dyx[k].y=x;dyx[k].hei=y;dyx[k].wyx=dyx[k].hei;k++;
                    dyx[k].x=z;dyx[k].y=y;dyx[k].hei=x;dyx[k].wyx=dyx[k].hei;k++;
                }
            }
        }
            sort(dyx,dyx+k,cmp);
            int ans=0;
            //将所有情况列出来,选取其中的最大子列和。
            for(int i=1;i<k;i++)
            {
                for(int j=0;j<i;j++)
                {
                    if(dyx[i].x>dyx[j].x&&dyx[i].y>dyx[j].y)
                    {
                        dyx[i].wyx=max(dyx[j].wyx+dyx[i].hei,dyx[i].wyx);
                    }
                        if(dyx[i].wyx>ans)
                        ans=dyx[i].wyx;
                }
            }
            cout<<"Case "<<Ti<<": maximum height "<<"= "<<ans<<endl;
        }
       return 0;
    }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值