ACM--steps--3.3.1--Bone Collector

Bone Collector

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 486 Accepted Submission(s): 239
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
 

Sample Output
14
 

Author
Teddy

#include<iostream>
#include<cstring>
using namespace std;
struct ws
{
    int val,wei;
}dyx[1005];
int wyx[1005][1005];//背包问题的dp方程。
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        //该状态转移方程为;
        //wyx[i][v]=max(dyx[i-1][v],dyx[i-1][v-i.wei]+i.val;
        //意义为:在当前背包容量为v的情况下,第i个物品到底放不放。
        memset(wyx,0,sizeof(wyx));
        int n,v;//n表示骨头的数目,v表示背包的总容量。
        cin>>n>>v;
        for(int i=1;i<=n;i++)
        cin>>dyx[i].val;
        for(int i=1;i<=n;i++)
        cin>>dyx[i].wei;
        for(int i=1;i<=n;i++)
        {
            for(int j=0;j<=v;j++)//从背包从0的时候计算。
            {
                if(j-dyx[i].wei>=0&&wyx[i-1][j]<wyx[i-1][j-dyx[i].wei]+dyx[i].val)
                //可以放进背包的话。
                wyx[i][j]=wyx[i-1][j-dyx[i].wei]+dyx[i].val;
                else
                //放不进背包
                wyx[i][j]=wyx[i-1][j];
            }
        }
        cout<<wyx[n][v]<<endl;
    }
    return 0;
}


一维数组的解法。
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
struct zr
{
    int wei,val;
}wyx[1010];
int dyx[1010];
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        memset(dyx,0,sizeof(dyx));
        int n,v;
        cin>>n>>v;//N表示骨头的数目,V表示背包的容量。
        for(int i=1;i<=n;i++)
        cin>>wyx[i].val;
        for(int i=1;i<=n;i++)
        cin>>wyx[i].wei;
        for(int i=1;i<=n;i++)
        {
            //在每次主循环中我们以v=V..0的顺序推dyx[v],这样才能保证推dyx[v]时dyx[v-c[i]]保存的是状态dyx[i-1][v-c[i]]的值
            for(int j=v;j>=wyx[i].wei;j--)
            {
                if(dyx[j]<dyx[j-wyx[i].wei]+wyx[i].val)
                dyx[j]=dyx[j-wyx[i].wei]+wyx[i].val;
            }
        }
        cout<<dyx[v]<<endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值