ACM--steps--4.1.3--Pie(二分)

16 篇文章 0 订阅
3 篇文章 0 订阅

Pie

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 665 Accepted Submission(s): 264
 
Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
 
Input
One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
 
Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
 
Sample Input
3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2
 
Sample Output
25.1327
3.1416
50.2655
 
 
Source
NWERC2006
 
Recommend
wangye


#include<iostream>
#include<cmath>
#include<algorithm>
#include<iomanip>
#include<cstring>
using namespace std;
double dyx[10009];
int n,m;//n表示馅饼的数量,m表示朋友的个数。
bool judge(double x)
{
    int num=0;
    //判断是否中间值可以都被分离出来。
    for(int i=1;i<=n;i++)
    {
        num+=(int)(dyx[i]/x);
    }
    if(num>=m)
    return true;
    else return false;
}
int main()
{
    double PI=acos(double(-1));//获取PI的值,对-1取反余弦函数。
    //double e=exp(double(1));//获取自然底数e的值
    int T;
    cin>>T;
    while(T--)
    {
        memset(dyx,0,sizeof(dyx));
        double sum=0;//表示所有馅饼的面积和。
        double r;
        cin>>n>>m;
        m++;//因为自己也会分到一个馅饼。
        for(int i=1;i<=n;i++)
        {
            cin>>r;//录入每个馅饼的半径。
            dyx[i]=r*r*PI;
            sum+=dyx[i];
        }
        //网上的分析说;把馅饼的面积和先算出来,然后先求出朋友们可以分得的最大的馅饼数。
        //然后用二分判断,判断条件是,取中间值,如果每个馅饼都可以分成这个中间值的面积,则这个值可取。
        double wyx=sum/m;
        double left=0.0;
        double right=wyx;
        double mid=0;
        while(fabs(left-right)>0.00001)
        {
            mid=(left+right)/2;
            if(judge(mid))//如果条件成立,则表示mid还可以再分。
            left=mid;
            else
            right=mid;
        }
        cout<<fixed<<setprecision(4)<<mid<<endl;
    }
    return  0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值