java web开发配置各种疑难杂症解决方案记录

1、The container 'Maven Dependencies' references non existing library

这个错误发生在,当我改变maven的pom.xml里面引用的包的版本的时候,他会去下载,然后可能是下载没有完成,或者是有什么错误,导致显示某个引用的jar,我到文件夹里面是有这个jar的,但是报找不到这个jar。

解决方法:对pom.xml右键,run as-maven build...-输入"clean package",点选"skip Tests",点击apply,点击run.

然后对项目右键-maven-update project...我测试是当我改了个版本号之后再update一次才成功。

2、Java compiler level does not match the version of the installed Java project facet

这个是说java编译版本不匹配。

对项目右键-properties,首先选择java compiler,里面的第一个选项compiler compliance level选择当前已经安装的版本,记得要点击apply;

java build path-libraries-JRE system library-edit-选择workspace default JRE-apply-ok,注意这个版本要跟刚才的版本一致。

3、Cannot change version of project facet Dynamic Web Module to 2.3

在项目下面-.setting-org.eclipse.wst.common.project.facet.core.xml-<installed facet="jst.web" version="3.0"/>改成3.0,然后刷新项目,然后把错误删掉。

4、打开marksers


点击箭头所指按钮就进入java EE模式,里面就有markers,项目默认是第3个按钮模式,即java模式,可以看到problems。

5、java路径的配置

配置路径的地方有3个,首先要在eclipse总设置里面配置,window-preferences-[java-install JRES-add-选中jdk的文件夹即可]

然后在项目里面配置,项目-右键-java compiler,level选择最高的,然后java build path-libraries-edit-选择workspace默认的那个jre。


阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/wzj0808/article/details/53857734
个人分类: java
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭