POJ 1979 Red and Black

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

给你一个x*y的矩阵,上面的'#'代表你不能走的地方,'.'表示你能走的地方,'@'表示你的起点,问你最多能走多少格。

<span style="font-size:14px;">#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
using namespace std;
char s[100];
int map[110][110];
int n,m,x,y,sum=0;
int d[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
void dfs(int a,int b){
	sum++;
	map[a][b]=0;
	for(int i=0;i<4;i++){
		int nx=a+d[i][0];
		int ny=b+d[i][1];
		if(nx>0 && ny<=n && ny>0 && nx<=m && map[nx][ny]!=0)
			 dfs(nx,ny);
	} 
}
int main(){
	int i,j,k,ans=0;
	while(scanf("%d%d",&n,&m)==2 && n!=0 && m!=0){
		sum=0;
		getchar();
		for(i=1;i<=m;i++){
			gets(s);
			for(j=0;j<n;j++)
				if(s[j]=='@'){map[i][j+1]=2;x=i;y=j+1;}
				else if(s[j]=='.')map[i][j+1]=1;
				else if(s[j]=='#')map[i][j+1]=0;
		}
		dfs(x,y);
		cout<<sum<<endl;		
	}
	return 0;
}</span>


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值