TKO 6-6 DP入门之村庄援助

搭桥问题
【pay attention】:low_bound(a,a+len,b)的具体意思是
在a数组中寻找第一个大于等于数字b的数字,
并且返回其位置。
Problem Description
‘Oh no, they’ve done it again’, cries the chief designer at the Waferland chip factory. Once more the routing designers have screwed up completely, making the signals on the chip connecting the ports of two functional blocks cross each other all over the place. At this late stage of the process, it is too
expensive to redo the routing. Instead, the engineers have to bridge the signals, using the third dimension, so that no two signals cross. However, bridging is a complicated operation, and thus it is desirable to bridge as few signals as possible. The call for a computer program that finds the maximum number of signals which may be connected on the silicon surface without rossing each other, is imminent. Bearing in mind that there may be housands of signal ports at the boundary of a functional block, the problem asks quite a lot of the programmer. Are you up to the task?

Figure 1. To the left: The two blocks’ ports and their signal mapping (4,2,6,3,1,5). To the right: At most three signals may be routed on the silicon surface without crossing each other. The dashed signals must be bridged.

A typical situation is schematically depicted in figure 1. The ports of the two functional blocks are numbered from 1 to p, from top to bottom. The signal mapping is described by a permutation of the numbers 1 to p in the form of a list of p unique numbers in the range 1 to p, in which the i:th number pecifies which port on the right side should be connected to the i:th port on the left side.
Two signals cross if and only if the straight lines connecting the two ports of each pair do.

Input
On the first line of the input, there is a single positive integer n, telling the number of test scenarios to follow. Each test scenario begins with a line containing a single positive integer p<40000, the number of ports on the two functional blocks. Then follow p lines, describing the signal mapping: On the i:th line is the port number of the block on the right side which should be connected to the i:th port of the block on the left side.

Output
For each test scenario, output one line containing the maximum number of signals which may be routed on the silicon surface without crossing each other.

Sample Input
4
6
4
2
6
3
1
5
10
2
3
4
5
6
7
8
9
10
1
8
8
7
6
5
4
3
2
1
9
5
8
9
2
3
1
7
4
6

Sample Output
3
9
1
4

其实AC代码很简短(但是lower_bound函数值得我们学习):
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 40010;
int main()
{
    int cas;
    scanf("%d",&cas);
    //测试的样例个数 
    
    while(cas--)
	{
         int n;
		 int len;
		 
         int a[maxn];
         
		 int b[maxn];
		 
		 //一个测试样例中的样例个数 
         scanf("%d",&n);
         
         //输入对应需要帮助的村庄 
         for(int i=1; i<=n; ++i)
         
            scanf("%d",&a[i]); 
            
         b[1] = a[1];//先初始化一条边 
         
         len = 1;
         
         for(int i=2; i<=n; ++i){
         	
             if(a[i]>b[len])
             
                 b[++len] = a[i];
                 
             else{
             	
                int  pos = lower_bound(b,b+len,a[i]) - b;
                //在b数组中找到第一个比它大的数, 
                
				b[pos] = a[i];
				//将那个比现在大的数向更小的方向转化,
				//在符合题意的情况下
				//(即不影响后面输入判断的情况下) , 
				// 正确地将后面的数字接在相应的数字后,
				//因为这么做可以让相应位置更小,
				//至少不比原来大的数字差,
				//略带有些贪心思想,符合极大升序列的寻找规律 
             
			 }
         
		 }
         
		 printf("%d\n",len);
    
	}
    
	return 0;

}

【important】😕/count记录个数,输出最长升序子序列;
//pos记录长度,通过锁定位置,来获得最大长度的数值 ;
//其实,这里可以将两个数组合并为一个数组!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值