Problem H: 今年第几天?



Problem H: 今年第几天?

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 620   Solved: 278
[ Submit][ Status][ Web Board]

Description

定义一个函数,其参数为年、月、日的值,返回这一天为该年的第几天。要求在main函数中输入年月日,然后调用这个函数求值,并在main函数中输出结果。

Input

年、月、日3个整数(不考虑非正常的年月日)

Output

这一天为这一年的第几天

Sample Input

1980 4 18

Sample Output

109

HINT

在下面代码基础上完成

#include<iostream>

using namespace std;

int days(int y, int m, int d);

int main()

{

     int year, month, day;

     cin>>year>>month>>day;

     cout<<days(year, month, day)<<endl;

     return 0;

}

int days(int y, int m, int d)

{ }



C代码  提交时要用C


#include<stdio.h>
 
int main()
{
    int year, mon, day, a, i, count;
    int month[13] = {0,31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
    scanf("%d%d%d", &year, &mon, &day);
    if ((year % 400 == 0) || (year % 100 != 0 && year % 4 == 0) )
        a=1;
    else a = 0;
    count = 0;
    month[2] = month[2] + a;
    for (i = 1; i < mon; i++)
    {
        count+= month[i];
    }
    count += day;
    printf("%d\n",count);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值