SDUT-2121 数据结构实验之链表六:有序链表的建立

数据结构实验之链表六:有序链表的建立

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description
输入N个无序的整数,建立一个有序链表,链表中的结点按照数值非降序排列,输出该有序链表。
Input
第一行输入整数个数N;
第二行输入N个无序的整数。
Output
依次输出有序链表的结点值。
Example Input
6
33 6 22 9 44 5
Example Output
5 6 9 22 33 44
Hint
不得使用数组!
Author
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
typedef struct node
{
    int data;
    struct node*next;
}str;
str*build(str*head,int n)
{
    str*p,*tail;
    p=head->next;
    tail=head;
    for(int i=0;i<n;i++)
    {
        p=(str*)malloc(sizeof(str));
        scanf("%d",&p->data);
        tail->next=p;
        p->next=NULL;
        tail=p;
    }
    return head;
}
void Sort(str*head,int n)
{
    int t;
    str*p,*q;
    for(p=head->next;p!=NULL;p=p->next)
    {
        for(q=p->next;q!=NULL;q=q->next)//将最小的排在最前边
        {
            if(p->data>q->data)
            {
                t=q->data;
                q->data=p->data;
                p->data=t;
            }
        }
    }
}
void print(str*head)
{
    str*p;
    p=head->next;
    while(p!=NULL)
    {
        printf("%d%c",p->data,p->next==NULL?'\n':' ');
        p=p->next;
    }
}
int main()
{
    int n;
    scanf("%d",&n);
    str*head;
    head=(str*)malloc(sizeof(str));
    head->next=NULL;
    head=build(head,n);
    Sort(head,n);
    print(head);
    return 0;
}


  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值