SDUT-1524 回文串判定(JAVA*)

48 篇文章 2 订阅

回文串判定

Time Limit: 1000 ms  Memory Limit: 65536 KiB
Problem Description

输入一串字符(长度小于100),判断该串字符是否是回文串(正序读与逆序读内容相同)。

Input

输入一串字符(长度小于100)。

Output

若该串字符是回文串输出“yes",否则输出”no“。

Sample Input
asdfgfdsa
Sample Output
yes
Hint

Source

参考:https://blog.csdn.net/u013248516/article/details/38044979

package leslie; //利用StringBuffer中的reverse方法创建新字符串和原字符串中字符挨个比较,若每个都相同则输出yes

import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner input = new Scanner(System.in);{
		String s = input.nextLine();
		StringBuffer ss=new StringBuffer(s);   //
		ss.reverse();   //
		int count=0;
		for(int i=0;i<s.length();i++)
		{
			if(s.charAt(i)==ss.charAt(i))   //charAt:返回字符串指定位置的字符
             count++;
		}
		if(count==s.length())
			System.out.printf("yes\n");
		else
			System.out.printf("no\n");
		}
		input.close();
}
}
package leslie; //利用StingBuffer中的reverse方法得到输入字符串的倒置字符串,直接和原字符串比较,若两者相等输出yes

import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner input = new Scanner(System.in);
		{
			String s = input.nextLine();
			StringBuffer ss = new StringBuffer(s);
			ss.reverse();  
			String sss = new String(ss);  //
			if (s.equals(sss))    //
				System.out.printf("yes\n");
			else
				System.out.printf("no\n");
			input.close();
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值