SDUT-2246 时间日期格式转换(JAVA*)

48 篇文章 2 订阅

时间日期格式转换

Time Limit: 1000 ms  Memory Limit: 65536 KiB
Problem Description
而北美所用的日期格式则为“月月/日日/年年年年”或”mm/dd /yyyy”,如将“2010/11/20”改成这种格式,对应的则是”11/20/2010”。对于时间的格式,则常有12小时制和24小时制
12小时制的表示方法是”05:30:00pm”。注意12:00:00pm表示中午12点,而12:00:00am 表示凌晨12点。
 第一行为一个整数T(T<=20),代表总共需要转换的时间日期字符串的数目。
<span 18px;="" \"="">接下来的总共T行,每行都是一个需要转换的时间日期字符串。
Output
 分行输出转换之后的结果
Sample Input
2
2010/11/20-12:12:12
1970/01/01-00:01:01
Sample Output
11/20/2010-12:12:12pm
01/01/1970-12:01:01am
Hint
 

Source



import java.util.*;
import java.text.*;

public class Main {
	static int t[] = new int[20];

	public static void main(String args[]) {
		Scanner cin = new Scanner(System.in);
		int n = cin.nextInt();
		String getchar = cin.nextLine();
		while (n-- > 0) {
			String s = cin.nextLine();
			String array[] = s.split("\\D");
			String ss = "";
			for (int i = 0; i < 6; i++)
				t[i] = Integer.parseInt(array[i]);
			int tt=t[0];
			t[0]=t[1];
			t[1]=tt;
			tt=t[1];
			t[1]=t[2];
			t[2]=tt;
			if (t[3] >= 13 && t[3] <= 23) {
				t[3] -= 12;
				ss = "pm";
			} else if (t[3] == 12)
				ss = "pm";
			else if (t[3] == 0) {
				t[3] += 12;
				ss = "am";
			} else if (t[3] >= 1 && t[3] <= 11)
				ss = "am";
			for (int i = 0; i < 6; i++) {
				if (t[i] < 10)
					System.out.print(0);
				if (i == 0 || i == 1)
					System.out.print(t[i] + "/");
				if (i == 2)
					System.out.print(t[i] + "-");
				if (i == 3) 
					System.out.print(t[i] + ":");
				if (i == 4)
					System.out.print(t[i] + ":");
				if (i == 5)
					System.out.println(t[i] + ss);
			}
		}
		cin.close();
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值