B - 抽屉

点击打开链接

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).
Input
The first line of the input contains the single number N. Each of next N lines contains one number from the given set.
Output
In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order. 

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.
Sample Input
5
1
2
3
4
1
Sample Output
2
2
3

题解: 设n个数分别为a[1],a[2],a[3],a[4]......a[n]

            设sum[1]=a[1],

                sum[2]=a[1]+a[2]

                sum[3]=a[1]+a[2]+a[3]

          ......sum[n]=a[1]+a[2]+a[3]+....+a[n]

                则每个sum[i]%n,共可能有n个结果。=0,1,2,3....n-1

                若含有sum[i]%n==0的情况,则输出i与a[1],a[2]...a[i]

               若没有则一定有两个sum对n取余相等,即sum[i]%n==sum[j]%n,则输出(j-i)与a[i+1],a[i+2].....a[j]




#include<cstdio>
#include<cstring>
int a[10005],sum[10005],yu[10005];
int main()
{
	int n,i,j;
	while(~scanf("%d",&n))
	{
		memset(yu,0,sizeof(yu));
		sum[0]=0;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			sum[i]=sum[i-1]+a[i];
		}
		for(i=1;i<=n;i++)
		{
			if(sum[i]%n==0)
			{
				printf("%d\n",i);
				for(j=1;j<=i;j++)
				  printf("%d\n",a[j]);
				break;
			}
			else if(yu[sum[i]%n]!=0)
			{
				printf("%d\n",i-yu[sum[i]%n]);
				for(j=yu[sum[i]%n]+1;j<=i;j++)
				  printf("%d\n",a[j]);
				break;
			}
			else if(yu[sum[i]%n]==0)
			    yu[sum[i]%n]=i;
		}
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值