ZCMU 2188: Frames【水】

3 篇文章 1 订阅

ZCMU 2188: Frames

Time Limit: 2 Sec  Memory Limit: 256 MB

Description

Throughout Igor K.'s life he has had many situations worthy of attention. We remember the story with the virus, the story of his mathematical career and of course, his famous programming achievements. However, one does not always adopt new hobbies, one can quit something as well.

This time Igor K. got disappointed in one of his hobbies: editing and voicing videos. Moreover, he got disappointed in it so much, that he decided to destroy his secret archive for good.

Igor K. use Pindows XR operation system which represents files and folders by small icons. At that, m icons can fit in a horizontal row in any window.

Igor K.'s computer contains n folders in the D: disk's root catalog. The folders are numbered from 1 to n in the order from the left to the right and from top to bottom (see the images). At that the folders with secret videos have numbers from a to b inclusive. Igor K. wants to delete them forever, at that making as few frame selections as possible, and then pressing Shift+Delete exactly once. What is the minimum number of times Igor K. will have to select the folder in order to select folders from a to b and only them? Let us note that if some selected folder is selected repeatedly, then it is deselected. Each selection possesses the shape of some rectangle with sides parallel to the screen's borders.

Input

The only line contains four integers nmab (1≤n,m≤109, 1≤abn). They are the number of folders in Igor K.'s computer, the width of a window and the numbers of the first and the last folders that need to be deleted.

Output

Print a single number: the least possible number of times Igor K. will have to select the folders using frames to select only the folders with numbers from a to b.

Sample Input

11 4 3 9
20 5 2 20

Sample Output

3
2

 

Note

The images below illustrate statement tests.

The first test:

In this test we can select folders 3 and 4 with out first selection, folders 5, 6, 7, 8 with our second selection and folder 9 with our third, last selection.

The second test:

In this test we can first select all folders in the first row (2, 3, 4, 5), then − all other ones.

题意

题目很长,前大半段都在讲故事,问题意思就是让你用尽量少的次数使用鼠标拖拽方式框选文件夹。本题内框选的运作方式:只能框选一个矩形,重复框选已选择的文件夹会取消其选择。输入文件夹总个数,窗口宽度,起终点文件夹号,窗口中的文件夹按编号升序排序,问最少需要框几次。

思路

撑死框三次嘛.......我们自己框一下就懂了

只需要框一次的情况:所有文件夹/一个文件夹/一行文件夹/矩形区域内的文件夹(头文件夹在行头,尾文件夹在行尾)以及各种头文件夹在行头,尾文件夹为最末文件夹的情况(最后一类情况并未考虑也AC)

框两次的情况:头尾文件夹中仅一个是不在行头/行尾的区域内的文件夹

注意特殊情况:分布于两行的文件夹,头文件夹位置比尾文件夹位置后一位的多行文件夹(第二种情况尝试删去也AC)

框三次为一般情况:排除以上情况之后的所有情况(头尾均不顶格,不在两行内,头不比尾后一位)

AC代码

#include <iostream>
#include <cstdio>
#include <vector>
#include <cstring>
#include <cmath>
#include <string>
#include <list>
#include <algorithm>
#include <set>
#include <list>
#include <stack>
#include <map>
 
using namespace std;
 
int main()
{
    //n:文件夹个数,m:窗口宽度,a:起始文件夹,b:结束文件夹
    int n, m, a, b;
    while (~scanf("%d%d%d%d", &n, &m, &a, &b))
    {
        int num;
        //判断起终点在不在同一行
        if ((a - 1) / m == (b - 1) / m)num = 1;
        else
        {
            //如果头文件夹在其行内的位置刚好比尾文件夹后1
            if (((a - 1) % m) - 1 == (b - 1) % m)num = 2;
            //如果头尾之间就差了一行
            else if ((a - 1) / m - (b - 1) / m == -1)num = 2;
            //如果头文件夹在行头
            else if((a-1)%m==0)
            {
                //尾文件夹在行尾
                if ((b - 1) % m == (m - 1))num = 1;
                else num = 2;
            }
            else if((b-1)%m==m-1)
            {
                num = 2;
            }
            else num = 3;
        }
        printf("%d\n", num);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值