POJ - 1797 Heavy Transportation

Heavy Transportation
Time Limit: 3000MS Memory Limit: 30000K
Description
Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 
Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5
Sample Output
Scenario #1:

4


题意就是要找出从i->j路径中最短的一条边可以达到的最大值是多少,按照dijkstra的套路,应该比较dis[3] 和 dis[2] + map[2][3] 的大小。但是这次有点不同在于只求一条边,不要整条路径。所以dis数组保存的就是从1->n的路径中最短的一条边是多少,那么,对于这个图中路径分成了两条,一是1->3 二是 1->2->3.所以dis[3]应该取第一条路径和第二条路径中最短边的最大值。

由于dis[3]本身就是一条路径中的最短边,所以不用处理,而第二条路径中,新增了一条2->3的边,所以应该比较一下dis[2]与map[2][3]的大小,取出最短边T。最后再去比较T与dis[3]去较大的,从而对第一条路径和第二条路径去进行取舍。

#include <cstdio>
#include <cstring>
#include <iostream>
#include <queue>
#include <vector>
#define inf 0x3f3f3f3f
using namespace std;
long matrix[1005][1005],dis[1005];
void init()
{
	for (int i = 0;i < 1005; i++){
		for (int j = 0; j< 1005; j++){
			if (i == j)
				matrix[i][j] = 0;
			else
				matrix[i][j] = -1;
		}
	}
}
void dijkstra(int n)
{
	bool vis[1005] = {true,true};
	for (int i = 1; i <= n; i++){
		dis[i] = matrix[1][i];
	}
	vis[1] = true;
	for (int i = 1;i < n; i++){
		long max = 0,total;
		for (int j = 1; j <= n; j++){
			if (!vis[j] && dis[j] > max){
				max = dis[total = j];
			}
		}
		vis[total] = true;
		for (int j = 1;j <= n; j++){
			long t = dis[total] < matrix[total][j] ? dis[total] : matrix[total][j];
			dis[j] = dis[j] > t ? dis[j] : t;
		}
	}
	printf ("%ld\n\n",dis[n]);
}
int main ()
{
	int k;
	scanf ("%d",&k);
	for (int i = 1;i <= k; i++){
		int m,n;
		init();
		scanf ("%d%d",&n,&m);
		for (int j = 1;j <= m; j++){
			long a,b,c;
			scanf ("%ld%ld%ld",&a,&b,&c);
			matrix[a][b] = matrix[b][a] = c;
		}
		printf ("Scenario #%d:\n",i);
		dijkstra(n);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值