Problem L. Graph Theory Homework

Problem L. Graph Theory Homework

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 2408    Accepted Submission(s): 1054


 

Problem Description

There is a complete graph containing n vertices, the weight of the i-th vertex is wi.
The length of edge between vertex i and j (i≠j) is ⌊|wi−wj|−−−−−−−√⌋.
Calculate the length of the shortest path from 1 to n.

 

 

Input

The first line of the input contains an integer T (1≤T≤10) denoting the number of test cases.
Each test case starts with an integer n (1≤n≤105) denoting the number of vertices in the graph.
The second line contains n integers, the i-th integer denotes wi (1≤wi≤105).

 

 

Output

For each test case, print an integer denoting the length of the shortest path from 1 to n.

 

 

Sample Input

 

1 3 1 3 5

 

 

Sample Output

 

2

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>

using namespace std;  

const int MAXN = 1e5+10;  
struct Node {
    int value;  
    int dian;
}node[MAXN];

int main(){
    int T;  
    scanf("%d", &T);  
    while(T--){
        int n;  
        scanf("%d", &n);  
        for(int i=1; i<=n; i++){
            scanf("%d", &node[i].value); 
            node[i].dian=i;  
        }
        
        int ans = sqrt(abs(node[1].value - node[n].value));  
        printf("%d\n", ans);  
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值