1008 QSC and Master (区间dp)

QSC and Master

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 176    Accepted Submission(s): 61


Problem Description
Every school has some legends, Northeastern University is the same.

Enter from the north gate of Northeastern University,You are facing the main building of Northeastern University.Ninety-nine percent of the students have not been there,It is said that there is a monster in it.

QSCI am a curious NEU_ACMer,This is the story he told us.

It’s a certain period,QSCI am in a dark night, secretly sneaked into the East Building,hope to see the master.After a serious search,He finally saw the little master in a dark corner. The master said:

“You and I, we're interfacing.please solve my little puzzle!

There are N pairs of numbers,Each pair consists of a key and a value,Now you need to move out some of the pairs to get the score.You can move out two continuous pairs,if and only if their keys are non coprime(their gcd is not one).The final score you get is the sum of all pair’s value which be moved out. May I ask how many points you can get the most?

The answer you give is directly related to your final exam results~The young man~”

QSC is very sad when he told the story,He failed his linear algebra that year because he didn't work out the puzzle.

Could you solve this puzzle?

(Data range:1<=N<=300
1<=Ai.key<=1,000,000,000
0<Ai.value<=1,000,000,000)
 

Input
First line contains a integer T,means there are T(1≤T≤10) test case。

  Each test case start with one integer N . Next line contains N integers,means Ai.key.Next line contains N integers,means Ai.value.
 

Output
For each test case,output the max score you could get in a line.
 

Sample Input
  
  
3 3 1 2 3 1 1 1 3 1 2 4 1 1 1 4 1 3 4 3 1 1 1 1
 

Sample Output
  
  
0 2 0
 

Source

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

typedef long long LL;
const int N = 305;

int n, f[N][N];
LL dp[N][N], key[N], sum[N];

int gcd(LL a, LL b){return b == 0 ? a : gcd(b, a % b);}

void DP_f()
{
    for(int i = 1; i < n; ++i) f[i][i+1] = gcd(key[i],key[i+1]) == 1? 0 : 1;
    for(int l = 3; l <= n; l++){
        for(int i = 1; i+l-1 <= n; i++){
            int r = i + l - 1;
            f[i][r] = (f[i+1][r-1] && gcd(key[i], key[r]) != 1);
            for(int j = i + 1; j < r; j++)
                f[i][r] += (f[i][j] && f[j+1][r]);
        }
    }
}

void DP_dp()
{
    for(int l = 2; l <= n; l++){
        for(int i = 1; l+i-1 <= n; i++){
            int r = l + i - 1;
            if(f[i][r]) {dp[i][r] = sum[r] - sum[i-1]; continue;}
            for(int j = i; j < r; j++)
                dp[i][r] = max(dp[i][r], dp[i][j] + dp[j+1][r]);
        }
    }
}

int main()
{
    int T;
    scanf("%d", &T);
    while(T--){
        LL val;
        sum[0] = 0;
        memset(dp, 0, sizeof(dp));
        memset(f, 0, sizeof(f));

        scanf("%d", &n);
        for(int i = 1; i <= n; i++) scanf("%lld", &key[i]);
        for(int i = 1; i <= n; i++) scanf("%lld", &val), sum[i] = sum[i-1] + val;

        DP_f();
        DP_dp();

        printf("%lld\n", dp[1][n]);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值