HDU_1060_leftmostdigt

题目:
Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 
Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
  
  
2 3 4
 
Sample Output
  
  
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
//For each test case, you should output the leftmost digit of N^N.

#include"stdio.h"
#include"math.h"

int comp(double num) {
    double x = num * log10(num * 1.0);
    double power = x - (long long)x;   <span style="color:#33ccff;"> </span><span style="color:#ff9900;">//32位的int对10^9会溢出,用64位整型long long or __int64。2^30 ≈ 10^9</span>
    return (int)pow(10.0, power);
}

int main() {
    int N;
    scanf("%d", &N);
    while(N--) {
        double num;
        scanf("%lf", &num);
        int result = comp(num);
        printf("%d\n", result);
    }
    return 0;
}

技巧:取对数计算。

num ^ num = a * 10^n;
a * 10^n 为 num*num的科学计数法, 0 < a < 1, a 的整数部分恰为 num^num 的最左一位
log10(num * num) = log10(a * 10^n);
==> num* log10(num) = n + log10(a);
==> log10(a) = 0.******, 而n为正整数 ==> log10(a) 为 x = num * log10(num) 的小数部分;
==> x - n = log10(a) , a = 10^(x - n);
==> 所求为(int)a;

注意输入1,000,000,000时使用__int64, 或 long long 64位整型
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值