1127 ZigZagging on a Tree (30 分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

 

#include<bits/stdc++.h>
using namespace std;
int in[1005],post[1005];
typedef struct node
{
    int data;
    struct node *lchild,*rchild;
}node,*Tree;
Tree Create(int inl,int inr,int postl,int postr)
{
    if(postl>postr)
        return NULL;
    Tree root = new node;
    root->data = post[postr];
    int k;
    for(k = inl;k<=inr;k++)
    {
        if(in[k]==post[postr])
            break;
    }
    int leftnum = k-inl;
    root->lchild = Create(inl,k-1,postl,postl+leftnum-1);
    root->rchild = Create(k+1,inr,postl+leftnum,postr-1);
    return root;
}

void bfs(Tree root)
{
    queue<Tree>q;
    q.push(root);
    cout<<root->data;
    int level=2;
    while(!q.empty())
    {
        vector<Tree>v;
        while(!q.empty())
        {
            Tree t= q.front();
            q.pop();
            if(t->lchild)
                v.push_back(t->lchild);
            if(t->rchild)
                v.push_back(t->rchild);
        }
        for(int i=0;i<v.size();i++)
            q.push(v[i]);
        if(level%2==0)
        {
            for(int i=0;i<v.size();i++)
                cout<<" "<<v[i]->data;
        }
        else
        {
            for(int i=v.size()-1;i>=0;i--)
                cout<<" "<<v[i]->data;
        }
        level++;
    }
}
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
        scanf("%d",&in[i]);
    for(int i=0;i<n;i++)
        scanf("%d",&post[i]);
    Tree root;
    root = Create(0,n-1,0,n-1);
    bfs(root);
}
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值