HDOJ 2057 A + B Again

Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !

Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.

Output
For each test case,print the sum of A and B in hexadecimal in one line.

Sample Input
+A -A
+1A 12
1A -9
-1A -12
1A -AA

Sample Output
0
2C
11
-2C
-90

如果你对java很熟,那这一题是很easy的,方法可以在API中查找

package cn.hncu;

import java.util.Scanner;

public class J2057 {
    public static void main(String[] args) {
        Scanner sc=new Scanner(System.in);
        while(sc.hasNext()){
            String str1=sc.next();
            String str2=sc.next();
            String s1=str1.replaceAll("\\+","");
//使用给定的 replacement 替换此字符串所有匹配给定的正则表达式的子字符串。 
//调用此方法的 str.replaceAll(regex, repl) 形式与以下表达式产生的结果完全相同: 
            String s2=str2.replaceAll("\\+","");
            long a=Long.parseLong(s1,16);
//将 string 参数解析为有符号的 long,基数由第二个参数指定。字符串中的字符必须为指定基数中的数字(由 Character.digit(char, int) 
//是否返回一个非负值来确定),除非第一个字符为 ASCII 字符的减号 '-' ('\u002D'),它表示一个负值。返回得到的 long 值。 
//          注意,不允许将字符 L ('\u004C') 和 l ('\u006C') 作为类型指示符出现在字符串的结尾处,
            //而这一点在 Java 编程语言源代码中是允许的——除非 L 或 l 以大于 22 的基数形式出现。 
            long b=Long.parseLong(s2, 16);
            long sum=a+b;
            if(sum<0){
                System.out.println("-"+Long.toHexString(-sum).toUpperCase());
            }else{
                System.out.println(Long.toHexString(sum).toUpperCase());
//使用默认语言环境的规则将此 String 中的所有字符都转换为大写。
            }
        }
    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值